Gossamer Forum
Home : Products : Links 2.0 : Discussions :

403 Forbidden error?

Quote Reply
403 Forbidden error?
Hi, I have recently tried to implement the Links v2 manager and am running in to a little difficulty. I have checked and double-checked my Links.cfg file, as well as my file permissions, but all to no avail.

I have been unsuccessful executing the nph-build.cgi from a telnet session (using: sh nph-build.cgi), so I tried executing the Build All function from the admin menu. This worked fine, however when I try to access the pages that the function created, I get a 403 Forbidden error from IE5 and Netscape.

I initially had the problem with the .db file permissions being changed, but have implemented the mod suggested by Alex.

My "pages" directory is chmod 777, along with everything in it...? What other file permission areas can I check?

URL is http://www.extremeanimation.com/cgi-bin/links/pages

Please help!!!

Thanks in advance,
Brian Burttram
Quote Reply
Re: 403 Forbidden error? In reply to
I seem to have a similar problem, after building all, my directories are set to 777 but my index.html files within them are showing the permissions -rw------- giving me a forbidden message when trying to access them.
I saw a similar post a while back but I cant seem to find it now, if anyone knows why or where that post was please let me know, all help appreciated, thanks.
Quote Reply
Re: 403 Forbidden error? In reply to
Well it seems its a server default with me, due to files being created across a network file system the default permissions unless chmod`ed by the script will be -rw-------
Here`s the good news, after the files have been intitially created and have the above permissions, then using telnet change all the permissions on all created *.html files to -rw-r--r-- now all the html pages are visible to the web, on further rebuilds the permissions are not changed, so it seems only when a file is created from scratch that this problem occurrs (if you create new categories they will need to be chmod`ed also.
The command I used for doing all files in telnet was

chmod 644 */*.html ; chmod 644 */*/*.html

this obviously only applies to my directory levels change yours to suit, the ; simply means you can put an extra function into the command line.

Hope that helps.
Quote Reply
Re: 403 Forbidden error? In reply to
I recently contacted my ISP to get their take on the situation. Below is a copy of the message I received, which did resolve my problem.

Thanks for your help, chmod...


From Illuminati Online:

The main problem that I'm seeing is that this set of web scripts is setup
with html, css, and image files that reside within the main cgi-bin
directory. Under this apache configuration, you can't do that.
Your root cgi-bin directory
(/virtual/customer/extremeanimation.com/cgi-bin/) is a 'scriptalias'
directory in the apache configuration, so anything that resides in that
directory is treated as a script for execution. Apache can't execute
html, css, or image files, and that's why it's not working.
Without modifying much of the scripts, I would suggest installing it in
your htdocs directory somewhere. As long as the scripts are set
executable, they hsould work (they don't have to be in the script-aliased
cgi-bin directory) and at the same time, you'll be able to view html, css,
and image files without apache trying to execute them as scripts.
Brent Alexander Oswald /\ http://www.io.com/~buzzboy
ILLUMINATI ONLINE /IO\ buzzboy@io.com
Webmaster /____\ NIC: BO525 FNORD!
Quote Reply
Re: 403 Forbidden error? In reply to
The easiest thing to do is put stuff the server calls --- cgi-bin\admin\.... in that directory, and in the \links\pages directory put your .css and an \links\pages\images directory.

This is easily done in the links.cfg file.

Files the _server_ tries to serve from a cgi-bin directory are attempted to be executed. Files that reside in the cgi-bin area but are called from a cgi program are ok, since the server only sees the output thats sent back to the browser, not the files themselves.

Quote Reply
Re: 403 Forbidden error? In reply to
I dont get where your isp`s coming from and pugdog all the built html pages should surely be made by scripts in your cgi-bin directory and created in your htdocs or whatever your docs directory is and your images should be there too.

I think your isp is saying that all your html pages are being made in your cgi-bin which is wrong, try making them in your docs directory, if you still get the same permissions then I reckon its a server default.

Quote Reply
Re: 403 Forbidden error? In reply to
The message from my ISP was correct, it was just the way the server is setup. As soon as I moved the html files in to my htdocs directory all was well... This thread can be closed. Thanks again for all of your help.

Quote Reply
Re: [chmod] 403 Forbidden error? In reply to
When I did a fresh install of Mandrake 8.2 with Apache I got this error when trying to access my websites that I had stored on another drive. I was upgrading from NT 2000 using IIS 5.0 so I had my original websites that were working before stored on another drive.

I spent 3 days looking for a solution to the 403 error I was getting when I tried accessing my websites. I had everything setup correctly in Apache (at least I thought). And I kept dinking around with my virtual server settings. I even changed the path in Apache for my default website to make sure it was not a webpage error.

My website pulled up fine when I did this but even though I duplicated the settings in my default site with the new Virtual site I created for my website I still got a 403 error.

The solution: You need to make the changes in the directives.

Once I added lines to my commonhttpd directive in Apache for my vitual server and the path where my websites were located I was then able to pull up my websites without this error showing up anymore. I have more information about the steps you go through to do this on my website.


I hope this helps others who maybe having the same problem I was.Crazy