Gossamer Forum
Quote Reply
Slow building pages
I changed servers and can't seem to build my pages
although I changed all the paths it takes forever to build
gets here and stops


Building HTML Pages: Building All Links.
Building HTML Pages: Building All Links.
Links SQL is now converting your entire directory into a series of HTML pages.
Started at Sun Sep 26 10:17:00 2004.
Creating backup file ...
Done (1.85 s)
Resetting hits and rates ...

Last edited by:

Abusaki: Sep 26, 2004, 9:26 AM
Quote Reply
Re: [Abusaki] Slow building pages In reply to
Try running it via SSH/Telnet :)

How large is your DB?

Quote:
Resetting hits and rates ...

This part can take a while to run. Depending on the number of links in your database ... I've seen it take as long as an hour to complete (on several million links). However, even on 100,000 links, on a "not-so-great" server, will cause it to go slow (for obvious reasons =)).

Otherwise, if you don't have SSH or Telnet... have you considered using "Build Staggered" ?

Hope that helps.

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Slow building pages In reply to
My database has about 3000 links,
I realized the links do not work you click on it, it takes forever and and give me an error
Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Quote Reply
Re: [Abusaki] Slow building pages In reply to
You should look into Apache error log.
Did you install a new plugin nowadays which may cause that error?
Did you made any kind of hack, or add new global?

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Quote Reply
Re: [webmaster33] Slow building pages In reply to
This is what I an getting in my error

[Mon Sep 27 12:46:14 2004] [error] [client 218.145.25.14] Premature end of script headers: jump.cgi
[Mon Sep 27 12:46:14 2004] [error] [client 218.145.25.14] failed to open log file /var/log/httpd/suexec_log
[Mon Sep 27 12:46:14 2004] [error] [client 218.145.25.14] fopen: Permission denied

I checked my perl path and it is right

Last edited by:

Abusaki: Sep 27, 2004, 12:06 PM
Quote Reply
Re: [Abusaki] Slow building pages In reply to
A general checklist would be this:
Check globals.txt, language.txt in your used template directories, if they're not corrupt.
Also check plugin.cfg, and ConfigData.pm (or Data.pm in LSQL 2.2.0).
Also check jump.cgi for syntax errors:
perl -c jump.cgi

But in this case it seems this is the key:
failed to open log file /var/log/httpd/suexec_log

Likely there is no more space available, or there is bad permission set.

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Quote Reply
Re: [Abusaki] Slow building pages In reply to
Looks like there is a permissions issue, on the log, your hosting company should look at.
Also, with the wrapper, make sure your executable programs have no permissions higher than 755, or they won't run. Also, make sure your directories have no permissions higher than 755, or some version will prevent running programs in "unprotected" directories.


PUGDOG´┐Ż Enterprises, Inc.

The best way to contact me is to NOT use Email.
Please leave a PM here.
Quote Reply
Re: [pugdog] Slow building pages In reply to
Thanks,
My logs files are fine since I have not other problems with it iwht my other sites
I have checked all my file permissions, but still it not building my pages
Quote Reply
Re: [webmaster33] Slow building pages In reply to
I tried to build vis SSH and this is what I got a bunch of errors here is an example


GT::SQL::Driver::MYSQL::sth (15357): Query execution took: 0.001138s at /home/XXXXXXXXXX/cgi-bin/admin/GT/SQL/Driver/MYSQL.pm line 121.
GT::SQL::Table (15357): Query: SELECT * FROM lsql_Reviews WHERE Review_Validated = ? AND ( Review_LinkID = ? )
GT::SQL::Driver::MYSQL (15357): Preparing query: SELECT * FROM lsql_Reviews WHERE Review_Validated = ? AND ( Review_LinkID = ? ) at /home/XXXXXXXXXX/cgi-bin/admin/GT/SQL/Driver/MYSQL.pm line 35.
GT::SQL::Driver::MYSQL::sth (15357): Executing query: SELECT * FROM lsql_Reviews WHERE Review_Validated = 'Yes' AND ( Review_LinkID = 3014 )
GT::Base (15357): GT::SQL::Driver::MYSQL::sth::execute called at /home/XXXXXXXXXX/cgi-bin/admin/GT/SQL/Table.pm line 950 with arguments
(GT::SQL::Driver::MYSQL::sth=HASH(0x87ec998), Yes, 3014).
GT::Base (15357): GT::SQL::Table::do_query called at /home/XXXXXXXXXX/cgi-bin/admin/GT/SQL/Table.pm line 866 with arguments
(GT::SQL::Table=HASH(0x860e5bc), SELECT * FROM lsql_Reviews WHERE Review_Validated = ? AND ( Review_LinkID = ? ) , ARRAY(0x885a300)).
GT::Base (15357): GT::SQL::Table::select called at /home/XXXXXXXXXX/cgi-bin/admin/Links/Link.pm line 377 with arguments
(GT::SQL::Table=HASH(0x860e5bc), HASH(0x880faec), GT::SQL::Condition=HASH(0x880fc30)).
GT::Base (15357): Links::Link::add_reviews called at Links::Build::build_detailed line 20 with arguments
(Links::Link=HASH(0x85afeec), ARRAY(0x8846490)).
GT::Base (15357): Links::Build::build_detailed called at /home/XXXXXXXXXX/cgi-bin/admin/GT/Plugins.pm line 108 with arguments
(HASH(0x88174ac)).
GT::Base (15357): GT::Plugins::dispatch called at /home/XXXXXXXXXX/cgi-bin/admin/Links/Build.pm line 30 with arguments
(GT::Plugins, /home/XXXXXXXXXX/cgi-bin/admin/Plugins, build_detailed, *Links::Build::build_detailed, HASH(0x88174ac)).
GT::Base (15357): Links::Build::build called at /home/XXXXXXXXXX/cgi-bin/admin/nph-build.cgi line 523 with arguments
(detailed, HASH(0x88174ac)).
GT::Base (15357): main::_build_detailed called at /home/XXXXXXXXXX/cgi-bin/admin/GT/Plugins.pm line 108 with arguments
(HASH(0x80626e0)).
GT::Base (15357): GT::Plugins::dispatch called at /home/XXXXXXXXXX/cgi-bin/admin/nph-build.cgi line 88 with arguments
(GT::Plugins, /home/XXXXXXXXXX/cgi-bin/admin/Plugins, create_detailed, CODE(0x8249f6c), HASH(0x80626e0)).
GT::Base (15357): main::build_all called at /home/XXXXXXXXXX/cgi-bin/admin/nph-build.cgi line 48 with no arguments.
GT::Base (15357): main::main called at /home/XXXXXXXXXX/cgi-bin/admin/nph-build.cgi line 30 with no arguments.
Quote Reply
Re: [Abusaki] Slow building pages In reply to
1) Turn off debugging in Setup > Misc Options.
2) Retry to build ... does it work?

The reason I ask, is because on some server's, if you set "debug" to "enabled", then it can clog up your error logs, with tons of debug messages (which, on slower servers, can cause 500 IS Errors).

Hope that helps.

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Abusaki] Slow building pages In reply to
There are not errors, just debug messages.
Do what Andy suggested.

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Quote Reply
Re: [webmaster33] Slow building pages In reply to
Thanks a lot Andy,
worked perfect