Gossamer Forum
Home : Products : Links 2.0 : Installation -- Windows :

Path problems...help

Quote Reply
Path problems...help
Ok server is running WinNT 4.0, IIS 4.0, & ActiveState 5.005
This is what i have done so far:
1. I changed all the filenames in *.cgi -> to *.pl scripts
2. Did a global search and replace for all occurances of *.cgi -> *.pl in all the script files
3. Edited the link.cfg file:
The scripts will be on D:\Inetpub\scripts\links\ hence for $db_script_path = "D:/Inetpub/scripts/links/admin";
(I had set the db_script_path to just "/scripts/links/admin" but that doesn't work so changed to full path "D:/Inetpub....")

I want the pages to be built in D:\Inetpub\wwwroot\Library\pages\ hence for
$build_root_path = "D:/Inetpub/wwwroot/Library/pages"

then ran the admin.cgi (now admin.pl) script.
It work!. Ok then I tried to add a category and gives me the following error:

Error Message : error in add_record. unable to open database: D:/Inetpub/scripts/links/admin/data/categories.db.
Reason: Permission denied
Script Location : D:\InetPub\scripts\links\admin\admin.pl
Perl Version : 5.00502

Obviously i have some path problems...but I don't know where I went wrong. I have already tried wiping the directory out and reinstalling and seeing if something different arises. Any help would be greatly appreciated.