Gossamer Forum
Home : Products : Links 2.0 : Discussions :

Division by zero error

Quote Reply
Division by zero error
I ran out of server space on my host and somehow the links databases have got screwed up. All links are still available and working but new links are not added. They appear in the admin program to be validated but when doing the build I get the error below after all links have been updated. I've tried restoring from a backup links.db but the same error appears when building. Any ideas anyone? Thanks. Error message follows ...


Updating ratings ..

Updating rating to 8.40 for link id 101



Error Message : fatal error: Illegal division by zero at nph-build.cgi line 432, line 385.

Script Location : nph-build.cgi

Perl Version : 5.006
Quote Reply
Re: [WebWalla] Division by zero error In reply to
Try searching the forum...this has been discussed literally hundreds of times...

Andy (mod)
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Division by zero error In reply to
Indeed, I should have searched first - sorry about that. I mistakenly thought that mine was such a particular situation that there wouldn't be any info available on the problem.

Anyway, deleting one of the rates files that had 0 bytes solved the problem. Thanks.