Gossamer Forum
Home : Products : Gossamer Mail : Discussion :

DBD::mSQL won't install

Quote Reply
DBD::mSQL won't install
I'm using a RAQ3 and CPAN to install the DBI drivers but it's having some major problems... if you've got a fix, let me know. Off to check the Cobalt usergroups...

Which drivers do you want to install?

1) MySQL only
2) mSQL only (either of mSQL 1 or mSQL 2)
3) MySQL and mSQL (either of mSQL 1 or mSQL 2)

4) mSQL 1 and mSQL 2
5) MySQL, mSQL 1 and mSQL 2

Enter the appropriate number: [3] 1

Do you want to install the MysqlPerl emulation? You might keep your old
Mysql module (to be distinguished from DBD::mysql!) if you are concerned
about compatibility to existing applications! [n]
Where is your MySQL installed? Please tell me the directory that
contains the subdir 'include'. [/usr/local/mysql]
Which database should I use for testing the MySQL drivers? [test]
On which host is database test running (hostname, ip address
or host:port) [localhost]
User name for connecting to database test? [undef]
Password for connecting to database test? [undef]
Creating files for MySQL ....................
Checking if your kit is complete...
Looks good
Note (probably harmless): No library found for -lgz
Using DBI 1.18 installed in /usr/local/lib/perl5/site_perl/5.6.1/i586-linux/auto/DBI
Writing Makefile for DBD::mysql
Writing Makefile for Msql-Mysql-modules
/usr/local/bin/perl -Iblib/arch -Iblib/lib -I/usr/local/lib/perl5/5.6.1/i586-linux \
-I/usr/local/lib/perl5/5.6.1 -Ilib -MExtUtils::PerlPP \
-e ppp "dbd/dbimon.in" "dbimon" "lib/DBD/mysql/Install/Config.pm"
/usr/local/bin/pod2text mysql/lib/DBD/mysql.pm >README
make[1]: Entering directory `/root/.cpan/build/Msql-Mysql-modules-1.2216/mysql'
cp lib/DBD/mysql.pm ../blib/lib/DBD/mysql.pm
cp lib/Bundle/DBD/mysql.pm ../blib/lib/Bundle/DBD/mysql.pm
cp lib/Mysql/Statement.pm ../blib/lib/Mysql/Statement.pm
cp lib/Mysql.pm ../blib/lib/Mysql.pm
cc -c -I/usr/local/lib/perl5/site_perl/5.6.1/i586-linux/auto/DBI -I/usr/local/mysql/include -I../dbd -I/usr/local/lib/perl5/site_perl/5.6.1/i586-linux/auto/DBI -I/usr/local/lib/perl5/5.6.1/i586-linux -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"2.0416\" -DXS_VERSION=\"2.0416\" -fpic -I/usr/local/lib/perl5/5.6.1/i586-linux/CORE -DDBD_MYSQL dbdimp.c
dbdimp.c: In function `MysqlReconnect':
dbdimp.c:2157: warning: assignment from incompatible pointer type
/usr/local/bin/perl -p -e "s/~DRIVER~/mysql/g" < /usr/local/lib/perl5/site_perl/5.6.1/i586-linux/auto/DBI/Driver.xst > mysql.xsi
/usr/local/bin/perl -I/usr/local/lib/perl5/5.6.1/i586-linux -I/usr/local/lib/perl5/5.6.1 /usr/local/lib/perl5/5.6.1/ExtUtils/xsubpp -typemap /usr/local/lib/perl5/5.6.1/ExtUtils/typemap mysql.xs > mysql.xsc && mv mysql.xsc mysql.c
Warning: duplicate function definition 'rows' detected in mysql.xs, line 381
cc -c -I/usr/local/lib/perl5/site_perl/5.6.1/i586-linux/auto/DBI -I/usr/local/mysql/include -I../dbd -I/usr/local/lib/perl5/site_perl/5.6.1/i586-linux/auto/DBI -I/usr/local/lib/perl5/5.6.1/i586-linux -fno-strict-aliasing -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -DVERSION=\"2.0416\" -DXS_VERSION=\"2.0416\" -fpic -I/usr/local/lib/perl5/5.6.1/i586-linux/CORE -DDBD_MYSQL mysql.c
Running Mkbootstrap for DBD::mysql ()
chmod 644 mysql.bs
rm -f ../blib/arch/auto/DBD/mysql/mysql.so
LD_RUN_PATH="/usr/local/mysql/lib:/lib:/usr/lib:/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66" cc -shared -L/usr/local/lib dbdimp.o mysql.o -L/usr/local/mysql/lib -o ../blib/arch/auto/DBD/mysql/mysql.so -L/usr/local/mysql/lib -lmysqlclient -lm -lz -L/usr/lib/gcc-lib/i386-redhat-linux/egcs-2.91.66 -lgcc
/usr/local/mysql/lib/libmysqlclient.a: could not read symbols: File format not recognized
collect2: ld returned 1 exit status
make[1]: *** [./blib/arch/auto/DBD/mysql/mysql.so] Error 1
make[1]: Leaving directory `/root/.cpan/build/Msql-Mysql-modules-1.2216/mysql'
make: *** [subdirs] Error 2
/usr/bin/make -- NOT OK
Running make test
Can't test without successful make
Running make install
make had returned bad status, install seems impossible

Quote Reply
Re: DBD::mSQL won't install In reply to
I just checked the MySQL .pkg and it was supposed to include the DBI modules...

RaQ3-RaQ4-MySQL 3.23.37-1 (8564 Kb) - A MySQL package that includes the server, client, shared files as well as the Perl DBI MySQL modules.

Anyone else have this problem on a RAQ3? Thanks in advance.

Quote Reply
Re: DBD::mSQL won't install In reply to
Ok, I ran a program that test's the DBI modules and here's what it gave:

[root@www /root]# perl test_dbi.pl
Here's a list of DBI drivers:

Yet the MySQL driver *should* be there since the package is installed, right? Not sure what to do at this point...

Quote Reply
Re: DBD::mSQL won't install In reply to
Fixed the problem. In case someone searches the forum and finds this... I had been trying to install DBD::mysql by

[root]# perl -MCPAN -e shell
cpan> install DBD::mysql

If I'm understanding this right there are more than one package to install the same driver, but this one I could clearly see was failing because it couldn't make a connection to the test database. It wanted to use root with no password, so the fix was to change the root mySQL password to nothing, install DBD::mysql, and then add the password again. You can read how to do that at http://www.mysql.com/...ault_privileges.html.

... and it installed fine. mysql now shows in the "modules installed" test:

[root@www /root]# perl test_dbi.pl
Here's a list of DBI drivers:

Quote Reply
Re: [winchell] DBD::mSQL won't install In reply to

I had worked on the DBD::mysql install multiple times (15+) and it was always dieing because it could not connect to the mysql server. This recommendation (to remove passwords) cured the problem the very first time!

Thank you!