Gossamer Forum
Home : Gossamer Threads Inc. : Discussion :

Gossamer Update

Quote Reply
Gossamer Update
Just wondering how the Gossamer Update works... will it automatically detect needed updates and automatically install them? If so, is there an option to turn off the auto-update and install manually... Would have a problem if it does un-attended autoupdates, and somehow crashed the program... basically, what are the options associated with the Gossamer Update???
Thanks,

</not a clue>
Quote Reply
Re: [Dinky] Gossamer Update In reply to
Hi,

There's nothing automatic about it. =) There is a new admin option that you can go to and check for any updates to the program. You can review each update and optionally decide to install it.

Cheers,

Alex
--
Gossamer Threads Inc.
Quote Reply
Re: [Alex] Gossamer Update In reply to
Hi

As already posted in Links forum, i got "Invalid License" on trying to run the upgrades after installing 2.99.1 on live site.

What are other information that is being read/gathered before upgrade really happens?
http://www.gossamer-threads.com/perl/gforum/gforum.cgi?post=279418

Thanks
HyTC
==================================
Mail Me If Contacting Privately Is That Necessary.
==================================

Last edited by:

HyperTherm: Mar 30, 2005, 9:05 AM
Quote Reply
Re: [Alex] Gossamer Update In reply to
Here's an example of what i see when i want to do the Fileman Fix...

Error: Update failed: Unable to download update file GT/FileMan.pm: Server returned error code: 200 - Invalid registration number The following updates are available for your Gossamer Links installation:

No critical updates
2 recommended updates
1 optional update Any Clues?

Thanks
HyTC
==================================
Mail Me If Contacting Privately Is That Necessary.
==================================
Quote Reply
Re: [HyperTherm] Gossamer Update In reply to
Hi,

We're working on a fix for this.

Cheers,

Alex
--
Gossamer Threads Inc.
Quote Reply
Re: [Alex] Gossamer Update In reply to
Alex,

While you are working on it, could add a "FORCE" option?

I had a site, that for some reason would not link in to the update area. I know there were new updates. I uninstalled the existing ones, and they did not show up as an option to re-download.

I ended up downloading the 2.99.1 and installing it manually over the old install.

Maybe a "repair" rather than a "force" would be a better option.

It would check all the core files, and stuff, make sure they matched, and gave you an option to re-download them. It makes backups, so any "damage" could be undone. For now, though, I'd settle for a "force" that downloaded all the core files again (minus any of the "custom" files like custom.css, luna.css, globals.txt, plugin.cfg, etc).

Also, an option to re-download the default templates :)

There are some quirks in the installer, but I know you are working on them, so "new features" or work arounds seem a better request ;)


PUGDOG´┐Ż Enterprises, Inc.

The best way to contact me is to NOT use Email.
Please leave a PM here.