Gossamer Forum
Home : Products : Others : MySQLMan :

Path question: Error says can't locate module in @INC

Quote Reply
Path question: Error says can't locate module in @INC
I realize there have been quite a few posts related to similar errors and I have searched, read, tried all the tips and solutions provided, but to no avail. Maybe there is something that I don't notice, but perhaps one you experts will.

I am trying to run MySQLMan for the first time after installation. At first I got a permissions error, so I changed the permissions (of .../templates/compiled/) to 666 instead of 644 listed in the readme file. This sorted out one error, but now I am getting another error:

Error Message : fatal undef error: Can't locate GT/Template/Parser.pm in @INC (@INC contains: /usr/home/domainname/cgi-bin/db .) at /usr/home/domainname/cgi-bin/db/GT/Template.pm line 538.

Script Location : /usr/home/domainname/cgi-bin/db/mysql.cgi
Perl Version : 5.00503

confirm_delete_record: 1
db_host_cookie_name : MySQLMan_host
db_pass_cookie_name : MySQLMan_password
db_user_cookie_name : MySQLMan_username
debug : 0
default_sort : 0
direct_connect : 0
direct_db : mysql
direct_host : localhost
direct_pass :
direct_port :
direct_user : root
dump_in_pages : 0
dump_page_length : 1000
home_url : /
insert_null : 1
insert_origin : insert
page_length : 20
script_url : /usr/home/domainname/cgi-bin/db/mysql.cgi
show_null : 1
show_timestamp_field: 0
template_dir : /usr/home/domainname/cgi-bin/db/templates
url_cookie_name : MySQLMan_url


Although @INC does show the correct path, it does not appear to work. I have tried all the permutations and combinations setting the following:

use lib '/usr/home/domainname/cgi-bin/db'; (in mysql.cgi)

$SCRIPT_PATH = '/usr/home/domainname/cgi-bin/db'; (in mysql.cgi)

script_url => "/usr/home/domainname/cgi-bin/db/mysql.cgi", (in mysql.cfg)

Any help, tips, advice will be be appreciated.