Gossamer Forum
Home : Products : Others : MySQLMan :

Cannot Find server

Quote Reply
Cannot Find server
Hi everyone,

I am quite new to MySQL and Perl and am having a lot of difficulties.
I have MySQL installed and MS Visual C++ 6.
I have also ActivePerl installed as I was already running a Perl based software (wonderdesk) which was based originally at one of the gosamer-threads products. This software is running fine... so the Perl installation and IIS seem to be ok.
I have also tried using MySQL and it works fine on its own.

My problem is that I wanted to use a user friendly tool that would allow user to submit a query via html (perl behind) and get the return of their query in html also. I ended up finding MySQLMan.

After I changed the URL in the MySQL.cgi and MySQL.cgf, I got an error saying that I id not have the DBI installed.

I installed it by running ppm> install DBI.

After that I got the same message for DBD. I did the same procedure.

Then I also installed the DBD::Mysql and DBD::Oracle.

Then the MySQL.cgi started working.

The thing is that the MySQL.cgi opens, but when trying any link or anything on that page, it gives the the error:

Page cannot be displayed Cannot find server or DNS Error
Internet Explorer


I also tried enabling the automatic logon, but the only difference is that it shows more links on the page, but none of them work.

Does anyone have any idea of what could be happening?

My whole intention is to create a way of making a query on a simple MySQL table that would have only 6 colums.

It will be used as a translation terms database.

So.. when you type a term in e.g. Italian, you would get the translation of that term in 5 other languages.

I already have all the data for the table. Now it is a matter of knowing how to install and run properly this MySQLMan.

Please let me know if you have a clue about what might be happening.

Thanks in advance


Leopoldo Innecco
Quote Reply
Re: [Innecco] Cannot Find server In reply to
Some servers give that page with a 500 IS Error. Try adding this line of code below the path to perl in mysql.cgi;

use CGI::Carp qw(fatalsToBrowser);

Then see what error that gives (if any...lol)


Andy (mod)
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Cannot Find server In reply to

Thanks for your answer. The thing is that this whole thing was getting so much on my nerves that I decided to uninstall everything so I can start from scratch again.

The only thing I left installed was Perl and IIS.

Would you recomend a way of doing it?

The this is that when I was installing, I got to a part where it talks about make, nmale, nmake install, etc...
I had no clue about what it was talking...

I know I might sound like a pain in the neck, but I am really willing to learn how to deal with it.

Would you be able to help me on installing MySQL properly and then installing MySQLMan ?
If you could send me a list of procedures, etc... I would REALLY appreciate.

Sorry if I am taking too much of your time.

Thanks again


Leopoldo Innecco
Quote Reply
Re: [Innecco] Cannot Find server In reply to
Forgot to mention....Sly

Now I have installed everything back again...

The this is that now when I try to open the mysql.cgi on the browser, it opens fine.
It even shows up all the databases I had in the Mysql/bin directory

But as soon as I click on ANY link on that page it asks me if I want to save the mysql.cgi file (I attached the screenshot)... how weird is that ?????????Shocked

Anyone could please give me a helping hand?


Leopoldo Innecco
Quote Reply
Re: [Innecco] Cannot Find server In reply to
Well... me again

Now I have replaced the old mysql.cgi and mysql.cfg with the original ones and have edited them again.
It opens fine now.

If I want to create a table, it says it will use a database called test (I created it).

The thing is that after I validate that creation, it says:


Connection to MySQL failed. A database name is needed for connection.

Database name:


So... I do not know why it cannot connect to the database. Any ideas?

Leopoldo Innecco