Gossamer Forum
Home : Products : Links 2.0 : Installation -- Windows :

errors with user dir after setting pword on admin

Quote Reply
errors with user dir after setting pword on admin
I've just had my provider password protect my admin directory (/cgi-bin/unzzipped/links/admin/). Now I get the following error when trying to access _any_ script in my user directory (/cgi-bin/unzzipped/links/):

Error including libraries: Can't locate e:/InetPub/vs200070/cgi-bin/unzzipped/links/admin/db_utils.pl in @INC (@INC contains: e:\InetPub\vs200070\cgi-bin\unzzipped\links e:\perl5\lib e:\perl5\lib\site e:\merchantserver\lib e:\perl5\lib\site e:\perl5\lib c:\perl\lib c:\perl\lib\site c:\perl\lib\site .) at e:\InetPub\vs200070\cgi-bin\unzzipped\links\add.pl line 36.

Make sure they exist, permissions are set properly, and paths are set correctly.

Initially I was getting a similar error message for links.cfg until I copied it into the user directory and changed the path in the user scripts.

Any suggestions? I was thinking that I may have to move all files included by the user scripts into directory that isn't password protected, would this create a security hole?

To answer some questions before they get asked:
hacks (all worked prior to passwd protecting):
* multiple catagories from online-sweepstakes.com
* moved templates, data and backup to directory without HTTP access
* changed site_html_print_cat in site_html_templates
* changed .cgi extension to .pl as my host hadn't associated .cgi - updated all references

I have changed all paths to absolute.

Pete Wilson
Quote Reply
Re: errors with user dir after setting pword on admin In reply to
I would recommend moving all your files and sub-folders outside of the admin to a NON-PASSWORD protected folder...leave the admin.cgi in the admin directory.


Eliot Lee