Gossamer Forum
Quote Reply
admin password
Admin.cgi tells me that I should protect my admin directory...

How can I get a password for my access to admin.cgi? Can I do it by myself, modifying any cgi ...or with permissions...or it is a regular password?

I can give permissions from a control panel (win NT) but I can not find the difference between admin, account, everyone and so on...I mean, I can only set write, read, execute...without specifying to whom..does it make sense to you?

Thanks
Francisco
Spain
Quote Reply
Re: admin password In reply to
You cannot protect the script on NT...without downloading and using third party software programs, like O'Reilly's Web Site1.1 or WebSite Pro.

Regards,

------------------
Eliot Lee....
Former Handle: Eliot
* Check Resource Center
* Search Forums
Quote Reply
Re: admin password In reply to
Hi, Thank you for your help.I managed to protect the admin directory but I have more problems now..
I am completely stuck with the installation so I will thank any help.....:-)

My hosting company (Win NT) requires .pl extensions so I changed my cgi files and, as you told me, also the references to them in the links.cfg and template files.
I understand that I must also change any other reference in other files like nph_build.cgi AND OTHERS (e.g. references like nph_build.cgi?staggered...)
Is this correct?

Other requirement is to change the UNIX "/" in the paths to the Win NT "\\". I did it in the links.cfg general path definitions but I have some doubts...
What happens with the references to the place to store headers and footers ? (."/header")...And more important to me , do I have to change ALL the path references including this types...

$build_use_templates ?
require "$db_lib_path/site_html_templates.pl" :
require "$db_lib_path/site_html.pl";

and even this...

$path .= "/$dir";

or this..

open (HIT, "$db_hits_path/$id")

or this makes the script portable for win NT?

($0 =~ m,(.*)/[^/]+,) && unshift (@INC, "$1"); # Get the script location: UNIX /
($0 =~ m,(.*)\\[^\\]+,) && unshift (@INC, "$1"); # Get the script location: Windows \

I followed the readme instructions carefully, I have my admin directory protected and set the permissions 8hopefully)(Win NT mode)..

I have tried different posibilities but the result is the admin.cgi (pl in my case) working except the Build All, Staggered options...
(they produce a "page not found" message) Any suggestions?

If I send to you the address, could you check the site? How do I have to do it? I mean, what do you need to know?

Thank you so much

Francisco
Quote Reply
Re: admin password In reply to
You need to change the links in the admin_html.pl to nph-build.pl rather than nph-build.cgi.

Regards.

------------------
Eliot Lee....
Former Handle: Eliot
* Check Resource Center
* Search Forums
Quote Reply
Re: admin password In reply to
And what happens with the "/"? Do I have to change ALL or only the ones in the links.cfg?

Quote Reply
Re: admin password In reply to
I don't understand your question.

Sorry.

Regards,

------------------
Eliot Lee....
Former Handle: Eliot
* Check Resource Center
* Search Forums
Quote Reply
Re: admin password In reply to
I apologize for my bad english...:-)

I changed the absolute path "\alex\links\..
and I wrote "E:\\xvrt\\enlaces.defensa.com\\html\\cgi-bin\\admin"

Do I have ALSO to change the code type..?

$build_use_templates ?
require "$db_lib_path/site_html_templates.pl" :
require "$db_lib_path/site_html.pl";

and write...?

$build_use_templates ?
require "$db_lib_path\\site_html_templates.pl" :
require "$db_lib_path\site_html.pl";


Thanks