Gossamer Forum
Home : Products : Links 2.0 : Installation -- Windows :

Protecting /admin directory on NT

Quote Reply
Protecting /admin directory on NT
Can anyone offer me a suggestion on how to password protect the /cgi-bin/links/admin directory?

I have had my server admin change the permissions (it asked me for my used name & password), but when I tried to access my links add/modify/rate I get an error saying could not find /admin/add.cgi (etc...) any suggestions?

Quote Reply
Re: Protecting /admin directory on NT In reply to
You probably have your directories set-up incorrectly in the admin.cgi file.


Eliot Lee
Founder and Editor
Anthro TECH, L.L.C
Coconino Community College
Web Technology
Quote Reply
Re: Protecting /admin directory on NT In reply to
Hi mjwood,
Been through the same not too long ago.
Basically what you are experiencing is a file lock. Your add, modify, and other frontend cgi files are requiring links.cfg to run. If you open the files you will see
require "folder/links.cfg";
It is on about line 30 of each of those cgi files.
What you a few choices:
1. Setup the file (links.cfg)in another folder outside your protected folders (this way is rather unsafe since most links runners know the default paths and can run it in browser to see your configuration),
2. Set up your your folder structure in your cgi-bin differently than your default,
ie. www.yoursite.com/cgi-bin/directory/control
currently the default is /cgi-bin/links/admin
by setting all your files to different locations, this makes it harder for wannabes to hack your area. then take you take and move your links.cfg file to another folder outside protection.
3. Do all the above and insert password authorization builder into the admin.pl script, whcih will log your ip and keep all others from loggin into your area and logout making hackers unable to spoof your site.

If you need any help on this let me know. I am currently working on an addon for NT users for better protection.

Oh after all the above, the main reason you are not able to do the current setup is your links.cfg is sitting behind the protection your admin setup and it is keeping your cgi files from running cause they do not have permission to access the reuired files.

Hope this helps.
Chris Chase