Gossamer Forum
Home : Products : Links 2.0 : Installation -- Windows :

Links SQL runs fine, 2.0 not

Quote Reply
Links SQL runs fine, 2.0 not
I have links SQL running on my main site and it's worked for years (http://www.babiesonline.com/links)

I just put a new domain on my server and am trying to install Links 2.0 for our church.

I changed the path to perl on 2.0 so it is the same as the path to perl on Links SQL, but I still get this error:

%1 is not a valid Win32 application.

I've looked through the support forums and the only answers I find don't apply, or at least I don't think they do, because of the above statements. Note, this is the same server, different domains and directories. Any suggestiosn?
Shannon Anderson
Babies Online.com
Quote Reply
Re: [BabiesOnline] Links SQL runs fine, 2.0 not In reply to
The following post may help:


Basically, make sure that the server is configured to execute CGI extension and that your scripts are in your cgi-bin folder.
Buh Bye!

Quote Reply
Re: [Stealth] Links SQL runs fine, 2.0 not In reply to
Yes, that's the post I read before posting myself. Permissions are correct for the cgi-bin. All scripts are loaded in the cgi-bin. Other scripts with a cgi extension work (including Links SQL). Path to perl is correct, but it's remarked anyway on both the working and non-working script so that's mute I guess.

I'm at a loss. Any other suggestions?
Shannon Anderson
Babies Online.com

Last edited by:

BabiesOnline: Sep 5, 2003, 2:34 PM
Quote Reply
Re: [BabiesOnline] Links SQL runs fine, 2.0 not In reply to
Works fine for me...let me know if you need any help !!
>> Nakul Goyal (SEO, Link Building Expert)
Web Site Promotion
Tips 'n' Tricks
SEO News

Quote Reply
Re: [nakulgoyal] Links SQL runs fine, 2.0 not In reply to
We can help you in free installation
Web Hosting Company
India Software Company
SEO Company

Quote Reply
Re: [BabiesOnline] Links SQL runs fine, 2.0 not In reply to
down vote
Instead of running your production server on Linux have you considered to run rails on Windows? I am currently developing an application using SQL Server and until know it seems to run fine.

These are the steps to access a SQL Server database from a Rails 2.0 application running on Windows.

The SQL Server adapter is not included by default in Rails 2. It is necessary to download and install it using the following command.

gem install activerecord-sqlserver-adapter
Download the latest version of ruby-dbi from


and then extract the file from ruby-dbi\lib\dbd\ADO.rb

to C:\ruby\lib\ruby\site_ruby\1.8\DBD\ADO\ADO.rb.

Warning, the folder ADO does not exist, so you have to create it in advance.

It is not possible to preconfigure rails for SQL Server using the --database option, just create your application as usual and then modify config\database.yml in your application folder as follows:

adapter: sqlserver
database: your_database_name
host: your_sqlserver_host
username: your_sqlserver_user
password: your_sqlserver_password
Run rake db:migrate to check your installation. If everything is fine you should not receive any error message.

Last edited by:

Andy: Sep 5, 2010, 11:56 PM