Gossamer Forum
Home : Products : Links 2.0 : Installation -- Unix :

Illegal character \015 with beta2?

Quote Reply
Illegal character \015 with beta2?
Has anyone installed the beta 2 successfully?

I just downloaded a copy and tried to install to my server, after following the instructions (linkcs.cfg, chmods), I ran admin.cgi to test it and received a 500 error. So I went to telnet and ran admin.cgi from the command line, here is what i got:

Illegal character \015 (carriage return) at /home/shweinc/www/cgi-bin/khayu/links/admin/db.pl line 19.
Content-type: text/plain

Error including libraries: (Maybe you didn't strip carriage returns after a network transfer?)

Make sure they exist, permissions are set properly, and paths are set correctly.

Thanks for your help.

P.S. What's Megalinks that I keep seeing in this forum?
Quote Reply
Re: Illegal character \015 with beta2? In reply to
You must have transfered the files by binary mode. Every files of the links are ascii files.

solution 1.
when transfering by ftp, use following procedure.

mget *

it will transfer all the files by ascii mode.

solution 2.
if you are used to using vi command, you can modifie all the files in vi.
the command is :1,$s/^M//
^M : ctrl-v and then press ctrl-m