Gossamer Forum
Home : Products : Links 2.0 : Installation -- Unix :

Error including libraries: Can't locate!

Quote Reply
Error including libraries: Can't locate!
Whenever i try to run the admin cgi at:

I get this error message. I have included a copy of the variables in my links.cfg file. I have changed some variables, but they dont show up as posted in the error message. My cgi bin is located in the "/cgi-bin" directory, but i have to reference it as just "cgi" for anything to work. Should i still keep the "cgi-bin" path for absolute paths? Im a little confused. Ive tried both and neither works, just get the same error message below:

Error including libraries: Can't locate /home/virtual/devi8/cgi-bin/links/admin/db.pl in @INC (@INC contains: /www/devi8/cgi-bin/links/admin /usr/lib/perl5/5.00502/i586-linux /usr/lib/perl5/5.00502 /usr/lib/perl5/site_perl/5.005/i586-linux /usr/lib/perl5/site_perl/5.005 .) at /www/devi8/cgi-bin/links/admin/admin.cgi line 28.
Make sure they exist, permissions are set properly, and paths are set correctly

My Links.cfg

# PATH and URL of Admin CGI directory. No Trailing Slash.
$db_script_path = "/home/virtual/www/devi8/cgi/links/admin";
$db_dir_url = "http://www.devi8.com/cgi/links/admin";

# URL of User CGI directory. No Trailing Slash.
$db_cgi_url = "http://www.devi8.com/cgi/links";

# PATH and URL of Pages to be built. No Trailing Slash.
$build_root_path = "/home/virtual/www/devi8/links";
$build_root_url = "http://www.devi8.com/links";

Did i list something wrong here? Path to Perl 5 is correct as are the permissions. Uploaded in correct mode also. the problem must lie in the configuration file settings above. Can someone help? TIA.
Quote Reply
Re: Error including libraries: Can't locate! In reply to
$db_script_path = "/home/virtual/www/devi8/cgi/links/admin";

According to the above, you use "/cgi/" as the name of the cgi-bin directory. Yet, the error message shows:

Can't locate /home/virtual/devi8/cgi-bin/links/admin/db.pl

Since the actual name of the directory is "cgi-bin" then that is what must be used in the "paths". The requirement to use just "cgi" is for the URLs.