Gossamer Forum
Home : Products : Links 2.0 : Discussions :

nph-build.cgi failing

Quote Reply
nph-build.cgi failing
I've hunted here for an answer, to keep from someone having to repeat themselves, but I can't find anything (that works).

Every once in a while, and usually after my host is down for a day (which is rare), my attempts to build are thwarted by this...

Error Message : unable to open what's new page: /home/akacooti/public_html/pepys/New/index.shtml. Reason: Permission denied
Script Location : nph-build.cgi
Perl Version : 5.006001

I have checked the permissions - 777 on the appropriate directories, 666 on the cgi files; I've experimented with variations on the CHMOD theme, and none have worked. I deleted the 'index.shtml' file (and forgot to back it up!), to no avail. Even when there's nothing there, is says 'permission denied'.

I did try to build it staggered (auto), and that worked - but only for directories in which nothing was being built. Anytime there was a build, the same error message - but it wouldn't last, because of the refresh in the HTML of the build pages.

This has happened before, and I was able to correct it though I don't recall how and I'd prefer a quick fix from people who know what they're doing.

The ownership of the file in this case is 'akacooti/akacooti', whcih is the case for many of the other files. Most, though, are 'nobody/nobody'

I did what I could before coming here and posting. I noticed a lot of people have asked about this - and posted their entire nph-build file - and I didn't want to have someone say 'look, dumbass...'.

Any thoughts on what might be the problem, especially a repeat problem like this? And, more importantly, any ideas on a solution?

The URL is http://pepys.akacooties.com

The script has run for a year now, with this happening twice before. Other than that, no problems at all.
Quote Reply
Re: [aka cooties] nph-build.cgi failing In reply to
One option would be to move all the link-created folders into a new directory (links-backup), for backup, which will make the script think none of the directories it needs exist, and it will then "start from scratch."

aka PerlFlunkie
Quote Reply
Re: [PerlFlunkie] nph-build.cgi failing In reply to
I'll give it a shot.

I did delete the index.shtml file it's currently stalling on, but it continued with the 'permission denied' stuff.

Oddly enough, in the same directory (/New), the 'date' files are being created and work fine.
Quote Reply
Re: [PerlFlunkie] nph-build.cgi failing In reply to
I want to have your children.

It worked.

I'm curious about why I have the problem so rarely but so fataly ...

but not that curious.

Onward and outward!