Gossamer Forum
Home : Products : Links 2.0 : Discussions :

What's New does not build new links, builds empty page

Quote Reply
What's New does not build new links, builds empty page
Moved to new server and now What's New page will not build with new links, builds empty page instead. I have searched the entire forum for hours now and have found various post about the same problem but Never a clear answer/reply/solution to the problem.

My server is Linux with perl 5.8.0

I have seen many posts having to do with same problem and cryptic answers having to do with Time::Local and using an older version of Local.pm and requiring it directly and other such vodoo - tried all of this nothing works.

Does anyone at Gossamer have a clear cut real solution? and if so could you POST the Actual code/solution here in reply. A simple here is Exactly what needs to be done would be great.

Thanks I hope!
Quote Reply
Re: [mikemikemike] Found a Local.pm that seems to solve problem In reply to
After trying a few copies of Local.pm on new system and What's new still not working I booted up an older machine with perl 5.005_03 grabbed the Local.pm from that machine and put a copy on new machine.

Commented out

#require Time::Local;

replaced with

require "Local.pm";

And it seems to work now, however I have not thouroughly checked to see if anything else might have gone awry.

Here is the copy of Local.pm I used that works.