Gossamer Forum
Home : Products : Links 2.0 : Discussions :

Problems w/ rating links

Quote Reply
Problems w/ rating links
Hi,

whenever I try to rate a link *nothing* happens except the rating page loads again and the value is set to its default "-".
Im using templates, the code for the rating form is
<table border="0" cellpadding="3" cellspacing="0" width="100%">
<tbody>
<tr align="left" valign="top">
<td>
<form action="<%db_cgi_url%>/rate.cgi" method="POST">
<input type="hidden" name="ID" value="<%ID%>">
<p>Please rate the link <a href="<%URL%>"><strong><%Title%></strong></a> between one and ten, with ten being tops.</p>
<div class="margin">
<p><select name="rate" size="1">
<option value="">---
<option value="">1
<option value="">2
<option value="">3
<option value="">4
<option value="">5
<option value="">6
<option value="">7
<option value="">8
<option value="">9
<option value="">10
</select> <input type="submit" value="Rate this Link"></p>
</div>
<p>
</form>
</td>
</tr>
</tbody>
</table>

(well, actually its copy/pasted), the code for link.html is

<ul><li><a class="link" href="<%db_cgi_url%>/jump.cgi?ID=<%ID%>"><%Title%></a><br>
<br>
<%if Description%>
<span class="descript">- <%Description%></span>
<%endif%><br>
<br>
<%if isNew%>
<small><sup class="new">neu</sup></small>
<%endif%>

<%if isPopular%>
<small><sup class="pop">pop</sup></small>
<%endif%><br>
<br>
<small class="date">(Seit: <%Date%> Hits: <%Hits%> Bewertung: <%Rating%> Stimmen: <%Votes%> ) <a href="<%db_cgi_url%>/rate.cgi?ID=<%ID%>">Bewerten</a></small>

</ul>

Anyone any ideas?

Thanks for your help,

Michael