Gossamer Forum
Home : Products : Links 2.0 : Customization :

WebAdverts, SSI, I've read every thread

Quote Reply
WebAdverts, SSI, I've read every thread
I have read every thread regarding Links 2 and WebAdverts. Because of the dates of messages posted it is not clear to me, if I must change the links.cfg $build_index ="index.shtml" and same for non index, and then do the mod that is found at this URL=>
http://www.codes-central.com/WebAdverts-Links.shtml

And when this is done, where do you write the SSI <!--#exec cgi="/cgi-bin/ads.pl"-->
In which file?

Thanks
Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
In your template files, like category.html, home.html, cool.html, etc.

You cannot use the SSI call codes for cgi generated pages, like add.html, add_error.html, add_success.html, etc.

Regards,

------------------
Eliot Lee
Anthro TECH,L.L.C
www.anthrotech.com
----------------------




Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
 
Oh

I tried that and that's why it does not work.

How about this, in the cgi generated pages you put an internal frame pointing to an ads.html page and that ads.html page has the SSI in.

<iframe src="" width=468 height=60 marginwidth=0 marginheight=0 hspace=0 vspace=0 frameborder="0" scrolling=NO>
<img width=468 height=60 border="0" ismap alt="" src="/images/templates/av/ads.html"></iframe>

Tony

[This message has been edited by chilli (edited January 09, 2000).]
Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
 
Yes

SSI now works for banners on the pages created using cgi generated pages.

http://www.cgi-factory.com
Advertisement Banner Rotator V2.0

There is one catch - click on the banner and it opens th site in the internal frame.

So I'll have to look at amending the ad-admin.pl so it opens in the correct window.

Any one got any suggestions.

If you want the srcipt email me

Cheers

Tony
Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
I am getting the banner placed on my index.shtml page, however I am not getting it on the "home" page, that is- when I click on "home" from the admin panel or when the page is called as domain.com/links/
Any ideas?
Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
Yea...You have to rebuild your index to see the changes you made in the home.html file.

Regards,

------------------
Eliot Lee
Anthro TECH,L.L.C
www.anthrotech.com
----------------------




Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
chilli,

I would recommend looking at the HTML codes in the perl script and re-write the codes so that the link will not appear in an "internal frame".

Without using or seeing the script, I don't know what else to suggest.

Regards,

------------------
Eliot Lee
Anthro TECH,L.L.C
www.anthrotech.com
----------------------




Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
Eliot,
I did rebuild. When I call tevye.net/links/ I don't get the same page as when I call tevye.net/links/index.shmtl
After a rebuild there are hypertext links in the report, and those call the .shtml, but in the template "add a resource" the HOME link is calling /links/ with out the .shtml. I understand that those other links are .cgi and you have to use the other method. I am just asking do I have to hand code all of those links to address the correct "index.shtml=home.html" page?
Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
Your home.html IS the index.shtml file that is created in the /links/ directory.

You need to delete the index.html file in that directory and all other index.html files generated by LINKS before you changed the extension to .shtml!!!!!

Your server is defaulting to index.html as the "home" page for your directories!

Regards,

------------------
Eliot Lee
Anthro TECH,L.L.C
www.anthrotech.com
----------------------




Quote Reply
Re: WebAdverts, SSI, I've read every thread In reply to
If you already have a large site and
already have many people linked to pages
within your site you may not want to change
all your pages to .shtml

here is my solution

I simply created a .htaccess file in the links
directory with the following

AddType text/html .html
AddHandler server-parsed .html
Options Indexes FollowSymLinks Includes

Now all my .html files in my links directories can contain ssi calls.

This doesn't however fix the SSI in CGI problems.

cheers
blurb

[This message has been edited by blurb (edited January 17, 2000).]