Gossamer Forum
Home : Products : Links 2.0 : Customization :

Modify/Password Mods Errors !!

Quote Reply
Modify/Password Mods Errors !!
I have installed the modify_first+password mods on my Links2, and had to face the following problems:

-error when trying to modify link: 'link not found'
==> fixed by browsing through threads.
had to add hidden ID input tags

-error when trying to modify link after that one was changed: 'category cannot be left blank'
==> fixed, Catergory to category, thanx to Eliot again.

Now, I have the following errors remaining, for which I am having a hard time finding info about in threads.

I think it also might be a CAPS problem, but duno where...

My errors:

-when user arrives in modify.html after modify_first, 'description' is not printed.


I have:

in modify.html
-------------
<tr>
<td align="right" valign="top">
<font color=white>Description:</td>
<td>
<textarea class="sexyblue" wrap="virtual" name="Description" value="<%Description%>" rows="3" cols="42">
</text-area>
</td>
</tr>

------------


in links.def
-------------
# Database Definition: LINKS
# --------------------------------------------------------
# Definition of your database file.
%db_def = (
ID => [0, 'numer', 5, 8, 1, '', ''],
Title => [1, 'alpha', 40, 75, 1, '', ''],
URL => [2, 'alpha', 40, 75, 1, 'http://', '^http|news|mailto|ftp'],
Date => [3, 'date', 15, 15, 1, \&get_date, ''],
Category => [4, 'alpha', 0, 150, 1, '', ''],
Description => [5, 'alpha', '40x3', 500, 0, '', ''],
'Contact Name' => [6, 'alpha', 40, 75, 1, '', ''],
'Contact Email' => [7, 'alpha', 40, 75, 1, '', '.+@.+\..+'],
Hits => [8, 'numer', 10, 10, 1, '0', '\d+'],
isNew => [9, 'alpha', 0, 5, 0, 'No', ''],
isPopular => [10, 'alpha', 0, 5, 0, 'No', ''],
Rating => [11, 'numer', 10, 10, 1, 0, '^[\d\.]+$'],
Votes => [12, 'numer', 10, 10, 1, 0, '^\d+$'],
ReceiveMail => [13, 'alpha', 10, 10, 1, 'Yes', 'No|Yes'],
Password => [20, 'alpha', 10, 10, 1, '', '']

);

# Database file to use -- defined in links.cfg.
$db_file_name = $db_links_name;
# Counter file to use -- defined in links.cfg.
$db_id_file_name = $db_links_id_file_name;
# The column name for the database key.
$db_key = 'ID';
# Database delimeter.
$db_delim = '|';
# Title used in admin output.
$html_title = 'Links Database';
$html_object = 'Link';

# Field Number of some important fields. The number is from %db_def above
# where the first field equals 0.
$db_category = 4; $db_modified = 3; $db_url = 2;
$db_hits = 8; $db_isnew = 9; $db_ispop = 10;
$db_contact_name = 6; $db_contact_email = 7; $db_title = 1;
$db_votes = 12; $db_rating = 11; $db_mail = 13; $db_password = 20;

-------------------




-my other error is with the password mod, when user asks for info to be emailed,
he receives this:


----------
You have requested your login info to -:hibrid:- for yello@www.com.
Resource ID: 12
URL : http://www.nk.com
Email : yello@www.com
password : 12

----------

notice pass=id ??????"('&"@|#|"'(&^???


I have the following for my password.cgi :
-----------------
#***********************************************************
# Use the info in links.def to find the values you want.
# These are the default values. If you have added fields, then
# make sure that you define it by $db_newfield = 14; and then
# to get the value, you can call it by $data[$db_newfield]
#
# $db_category = 4; $db_modified = 3; $db_url = 2;
# $db_hits = 8; $db_isnew = 9; $db_ispop = 10;
# $db_contact_name = 6; $db_contact_email = 7; $db_title = 1;
# $db_votes = 12; $db_rating = 11; $db_mail = 13; $db_newfield = 20;
#**********************************************************

open (MAIL_RECIP, "|$MAIL_PROGRAM");

print MAIL_RECIP "To: $email\n";
print MAIL_RECIP "From: $admin\n";
print MAIL_RECIP "Subject: Password Request\n";

print MAIL_RECIP "You have requested your login info to -:hibrid:- for $email.\n";

print MAIL_RECIP "Resource ID: $data[0]\n";
print MAIL_RECIP "URL : $data[$db_url]\n";
print MAIL_RECIP "Email : $data[$db_contact_email]\n";
print MAIL_RECIP "password : $data[$db_newfield]\n";


close(MAIL_RECIP);

} # end of foreach

-----------------------



If anyone has any suggestions, it would be great,Tongue

Thanks in advance,
Aymeric.

Subject Author Views Date
Thread Modify/Password Mods Errors !! Aymeric 2854 Dec 9, 2000, 1:29 PM
Thread Re: Modify/Password Mods Errors !!
Aymeric 2804 Dec 10, 2000, 5:36 PM
Post Re: Modify/Password Mods Errors !!
Aymeric 2782 Dec 20, 2000, 5:59 PM
Thread Re: Modify/Password Mods Errors !!
Stealth 2769 Dec 20, 2000, 6:47 PM
Post Re: Modify/Password Mods Errors !!
Aymeric 2782 Dec 21, 2000, 4:12 AM
Thread Re: Modify/Password Mods Errors !!
doororjon 2760 Jan 1, 2001, 12:42 PM
Thread Re: Modify/Password Mods Errors !!
Aymeric 2722 Jan 3, 2001, 4:58 PM
Thread Re: Modify/Password Mods Errors !!
doororjon 2764 Jan 3, 2001, 8:48 PM
Thread Re: Modify/Password Mods Errors !!
Aymeric 2737 Jan 4, 2001, 4:28 AM
Thread Re: Modify/Password Mods Errors !!
Aymeric 2715 Jan 4, 2001, 4:53 AM
Post Re: Modify/Password Mods Errors !!
esm 2714 Jan 4, 2001, 8:21 PM
Thread Re: Modify/Password Mods Errors !!
doororjon 2649 Jan 6, 2001, 11:57 AM
Post Re: Modify/Password Mods Errors !!
Aymeric 2644 Jan 7, 2001, 4:29 AM