Gossamer Forum
Home : Products : Gossamer Mail : Discussion :

protocol error connecting to POP3

Quote Reply
protocol error connecting to POP3
Like some other people, I haven't been able to connect to my POP3 server using Gossamer Mail. I have a system POP3 account that matches the Gossamer Mail account. The error I'm getting is :
[Sat Jul 15 23:10:49 2000] webmail.cgi: Webmail (29222): Getting messages from POP.
[Sat Jul 15 23:10:49 2000] webmail.cgi:
[Sat Jul 15 23:10:49 2000] webmail.cgi: POP3 (29222): New pop object created.
[Sat Jul 15 23:10:49 2000] webmail.cgi: POP3 (29222): Attempting to connect ..
[Sat Jul 15 23:10:49 2000] webmail.cgi: POP3 (29222): Could not connect to server [110, _j]: Address family not supported by protocol family
[Sat Jul 15 23:10:49 2000] webmail.cgi: POP3 (29222): --> QUIT
[Sat Jul 15 23:10:49 2000] webmail.cgi: POP3 (29222): <--
[Sat Jul 15 23:10:49 2000] webmail.cgi: POP3 (29222): Closed connection.
[Sat Jul 15 23:10:49 2000] webmail.cgi: POP3 (29222): POP Object destroyed.

I've found the code responsible in POP3.pm starting at line 164 :
# Look up the domain name.
if (! defined $self->{ADDR}) {
my $addr = ($self->{HOST} =~ /^(\d{1,3})\.(\d{1,3})\.(\d{1,3})\.(\d{1,3})$/) ?
pack('C4',$1,$2,$3,$4) : (gethostbyname($self->{HOST}))[4];
$self->{ADDR} = $addr;
}
$self->{ADDR} or croak "POP3 ($$): Unable to parse host name: ", $self->{HOST}, "\n";

# Connect to the pop box.
socket ($s, PF_INET, SOCK_STREAM, getprotobyname("tcp") || 6) or return error "POP3 ($$): Could not open soc$
connect ($s, pack('Sna4x8', AF_INET, $self->{PORT}, $self->{ADDR}) ) or return error "POP3 ($$): Could not conn$

Unfortunately, I don't know enough about POP3 to see what's wrong. Can anyone figure this one out?

Thanks!
-Michael J

Subject Author Views Date
Thread protocol error connecting to POP3 Michael_J 3697 Jul 15, 2000, 11:39 PM
Thread Re: protocol error connecting to POP3
Michael_J 3583 Jul 15, 2000, 11:54 PM
Thread Re: protocol error connecting to POP3
Alex 3568 Jul 18, 2000, 12:42 PM
Thread Re: [Alex] protocol error connecting to POP3
ryel01 3222 Sep 8, 2003, 2:33 PM
Thread Re: [ryel01] protocol error connecting to POP3
Alex 3213 Sep 8, 2003, 5:18 PM
Post Re: [Alex] protocol error connecting to POP3
ryel01 3202 Sep 8, 2003, 5:24 PM