Gossamer Forum
Home : Products : Gossamer Mail : Discussion :

incoming.pl problems

Quote Reply
incoming.pl problems
I have cron set to run incoming.pl every 10 minutes. On about every other attempt cron sends me the following message...

Lockfile already exists pid: (13486) No such file or directory
BEGIN failed--compilation aborted at /home/pmfb/cgi-bin/webmail/batch/incoming.pl line 661, <LOCK> chunk 1.

It looks like incoming.pl creates a lock file when it starts. It checks for the lock file each time it starts to make sure that more than one instance is not running.

So, it looks like the lock file is being created, but not always being removed? Anyone seen this problem or know what might cause it? One thing I have not seen in the documentation is what the permissions and ownership should be for each file. Not sure if that could cause this problem, but would be nice to know anyway.

thanks,

Michael Coyne
seaturtle.org

PS - Great job Alex and GT!

seaturtle.org
Quote Reply
Re: incoming.pl problems In reply to
I think I am having the same problem. I do not have access to cron jobs so I have been running incoming.pl from a shell while I am testing it. It locks up after the first time I run it. I have to wait a while for it to work again. I do not get any error messages so I cannot say for sure if itís the same problem.

CP

Quote Reply
Re: incoming.pl problems In reply to
Hi,

This is a bug in the POP3.pm module that locks up if there are no messages waiting. We updated the version in the download area so you can grab a new one there, or drop me an email and I'll send it to you.

Cheers,

Alex

--
Gossamer Threads Inc.
Quote Reply
Re: incoming.pl problems In reply to
Hi Alex, I installed the POP3.pm file you sent and I am still having the same problem. incoming.pl hangs when there are no e-mails in the pop3 account.

Thanks
CP