Gossamer Forum
Home : Products : Gossamer Mail : Discussion :

Unknown method- Messages.pm

Quote Reply
Unknown method- Messages.pm
Unknown method GMail::Messages::format_msgs_row at
/../GMail/Messages.pm line 160, line 35.

Line 160 is the function AUTOLOAD, line 35 is mime-type.

Could it be that the template cause this problem (a html tag style that it thinks is a function) ? Why does it only effect some users ? Could it be mod_perl that is making this problems ?

I have experience a lot of error lately, like "The page requested (msgs_body.htm) is not found or invalid", or tags that suddenly is missing. If I login again, sometimes the error is gone. I downloaded the complete upgrade yeasterday.

I have sometimes gotten other messages like 'Unknown tag: msg_body'. The next time I click the message, the error is gone. Strange...


Quote Reply
Re: Unknown method- Messages.pm In reply to

Did you make sure you restarted mod_perl after upgrading or changing any of the files?



Gossamer Threads Inc.
Quote Reply
Re: Unknown method- Messages.pm In reply to

Yes, at least I have restarted the server.

Afterwards, when starting apache, I get this error:
./apachectl start
defined(@array) is deprecated at /usr/local/lib/perl5/site_perl/5.6.0/Apache/DBI.pm line 135.
(Maybe you should just omit the defined()?)
"my" variable $format masks earlier declaration in same scope at GMail::Messages::parse_date line 20.
Preloading Gossamer Mail scripts into mod_perl:
. . . . . . . . . . . . . . . . . . . . .
All scripts compiled and loaded ok!

./apachectl start: httpd started

Quote Reply
Re: Unknown method- Messages.pm In reply to
I also seems to have problem with Links 2.0.4 related to mod_perl. I have both speedy_cgi and mod_perl. speedy_cgi had /usr/bin/speedy_cgi as perl path set in Links SQL. Since I use mod_perl, this wasn´t used.

I tried to deactivate mod_perl by removing the start line in apache, and the alias cgi path for mod_perl. However, when I do this the admin area won´t load, only the <html></html> is in the html source. I thought the speedy_cgi took over, and it was something wrong with that too, so I activated mod_perl again, set path to normal perl path, deactivated mod_perl, and tried again. Still no admin area (/admin/admin.cgi) shown. But I still see that speedy_cgi generates a temp file on the server each time I access admin.cgi.

Perl Version: 5.006
Links SQL Version: 2.0.4
DBI.pm Version: 1.14
Persistant Env: mod_perl (1) SpeedyCGI (0)
Mod Perl Version: 1.25