Gossamer Forum
Home : Products : Gossamer Mail : Discussion :


Quote Reply

My gmail send letters but does not receive even though the cronjob for incoming.pl is working and the catch mail has been setup correct,when I checked my error logs I found the following message:


ORDER BY folders_fid at /home/user/public_html/cgi-bin/admin/GT/SQL/Driver/MYSQL.pm line 35.
GT::SQL::Driver::MYSQL (13348): Preparing query: SELECT COUNT(*) FROM msgtrack WHERE msgtrack_fid = '1' AND msgtrack_status = 'New' AND msgtrack_userid = '2' at /home/user/public_html/cgi-bin/admin/GT/SQL/Driver/MYSQL.pm line 35.


I tried my best to fix the problem by changing directory and file permissions to 0777 hoping it mite help but the error is still there and I can not receive any mail.

Also I would like to know what are the correct permissions for directories and .cgi ,.pl .pm files?and does it really matter if all my files and directories are set to 0777?I mean security of gmail?

Please help,


Quote Reply
Re: [nas9] GT::SQL::Driver::MYSQL PROBLEM In reply to

This just looks like debug output. Go to your admin, and under Setup->Misc, make sure debug level is empty.

You should generally not change permissions of the files unless you have a reason to do so.


Gossamer Threads Inc.
Quote Reply
Re: [Alex] GT::SQL::Driver::MYSQL PROBLEM In reply to
Hi Alex,

ok I ignored the debug output,but now what?

I'm still not receiving any mail!

I have installed gmail 7 times yesterday looking for a mistake that I have may done but did not find a clue.

is it my cronjob?well it mite be,so here how I have set the cron job:

I have a file called "cronfile" that I have already put them two lines in there:

0,5,10,15,20,25,30,35,40,45,50,55 * * * * /home/gogo/public_html/cgi-bin/batch/incoming.pl
0,5,10,15,20,25,30,35,40,45,50,55 * * * * /home/gogo/public_html/cgi-bin/batch/outgoing.pl

then I uploaded the file "cronfile" to the batch directory then entered the batch directory by SSH and used the command:

bash$crontab cronfile

after the command was excepted I typed:

bash$crontab -l

and got the same two lines I have added to the file "cronfile" which I think means that the cron was excepted.

That is all what I did,any problems please?