Gossamer Forum
Home : Products : Gossamer Mail : Discussion :

Bare LFs in SMTP

Quote Reply
Bare LFs in SMTP
Mailer (14516): Didn't like end of msg (451 See http://pobox.com/~djb/docs/smtplf.html. ) in Mailer line 473 at /home/wpsrl1/www/cgi-bin/wm/webmail.cgi line 484

Your mailer tried to send an e-mail message to a server running qmail. Unfortunately, qmail spotted a problem: your mailer sent a bare LF.

I think GT Webmail use that bare LF so it wont go trough the SMTP ... any solution ??? ( i cannot use sendmail cause the smtp is on another machine )...

If I tried to use the sendmail, it fails...
for example I had the user tizo@mydomain.com and when I
send a mail in my logs the mail appears to be sended from nobody@hostwithsendmail ... so if a bounce occured the user will never be notified....any clue ?


Quote Reply
Re: Bare LFs in SMTP In reply to

Can you try editing Webmail/Mailer.pm and change:

$CRLF = "\n";


$CRLF = "\r\n";

Let me know if that works.



Gossamer Threads Inc.
Quote Reply
Re: Bare LFs in SMTP In reply to
Alex, I tried to edit that $CRLF, but nothing changed...

QMail still complain for bare LF.

Quote Reply
Re: Bare LFs in SMTP In reply to
I did some tests...

It seems the error is not in the final print $s $CRLF, '.' , $CRLF;

(altought i changed $CRLF to \r\n)

in fact if i comment out the $self->print($s) in sub send_by_smtp in Mailer.pm, the message will be send...(although is empty naturally...but qmail doesn't complain on bare LF...so all the cycle HELO, MAIL FROM, RCPT TO, DATA, QUIT works....)

so i think problem is not in the end of message ( there's no check in Mailer.pm between DATA and QUIT ), but IN the messages...

Well...just sharing my tougths ...trying to figure it out :)