Gossamer Forum
Home : Products : Gossamer Links : Version 1.x :

Re: search.cgi - lots of hung processes

Quote Reply
Re: search.cgi - lots of hung processes In reply to
Okay, here's the latest on the memory problems .... and, yes, I'm still having some trouble.

Although the updated search.cgi doesn't hang any more, I'm still loosing a large chunk of memory, and I believe I've isolated it to the nph-build.cgi operation, or something related.

For the past week available free memory has been hovering around 15000k and yesterday, after a busy half an hour of activity, the server fell over and ran out of free mem. I did a remote shutdown/reboot of the server and after starting Apache I found I had gained roughly 45000k above what I've had available recently - much to my surprise, as I'd been pretty sure from the start that I should have had more free mem.!!

Everything ran OK and there was loads of free mem. until I did a rebuild this afternoon, after which I'm back down to around 15000-10000k again.

I'm running nph-build.cgi through Putty ssh from the command line with the ' -all ' tag. Any idea why nph-build.cgi would casue the memory to disappear, or could there be something else that is triggered by nph-build that doesn't quit afterwards?

As usual, any and all help appreciated, and if you think I should move this to the PERL, SQL and more forum please let me know and I'll start a new thread there Smile


All the best
Shaun

Subject Author Views Date
Thread search.cgi - lots of hung processes qango 7266 May 31, 2001, 10:08 AM
Thread Re: search.cgi - lots of hung processes
Stealth 7160 May 31, 2001, 12:41 PM
Thread Re: search.cgi - lots of hung processes
qango 7132 May 31, 2001, 2:20 PM
Thread Re: search.cgi - lots of hung processes
Stealth 7179 May 31, 2001, 2:23 PM
Thread Re: search.cgi - lots of hung processes
qango 7178 Jun 1, 2001, 2:59 AM
Thread Re: search.cgi - lots of hung processes
Paul 7136 Jun 1, 2001, 3:21 AM
Thread Re: search.cgi - lots of hung processes
qango 7120 Jun 1, 2001, 5:17 AM
Thread Re: search.cgi - lots of hung processes
Paul 7115 Jun 1, 2001, 5:23 AM
Thread Re: search.cgi - lots of hung processes
qango 7103 Jun 1, 2001, 8:31 AM
Thread Re: search.cgi - lots of hung processes
Paul 7105 Jun 1, 2001, 8:36 AM
Thread Re: search.cgi - lots of hung processes
qango 7120 Jun 1, 2001, 1:03 PM
Post Re: search.cgi - lots of hung processes
Paul 7102 Jun 1, 2001, 1:09 PM
Thread Re: search.cgi - lots of hung processes
Alex 7112 Jun 1, 2001, 3:22 PM
Thread Re: search.cgi - lots of hung processes
qango 7114 Jun 2, 2001, 5:01 AM
Thread Re: search.cgi - lots of hung processes
qango 7037 Jun 7, 2001, 3:29 PM
Thread Re: search.cgi - lots of hung processes
qango 7027 Jun 19, 2001, 7:57 AM
Thread Re: search.cgi - lots of hung processes
Paul 7018 Jun 19, 2001, 8:58 AM
Thread Re: search.cgi - lots of hung processes
qango 7041 Jun 19, 2001, 11:29 AM
Post Re: search.cgi - lots of hung processes
qango 6984 Jun 25, 2001, 12:20 PM