Gossamer Forum
Home : Products : Gossamer Links : Version 1.x :

Editors Session Bug solved!!

Quote Reply
Editors Session Bug solved!!
It's really a lot of time I couldn't find a way to use the Editor session. For some strange ways LinksSQL did not allow me to enter saying all the time.. Invalid Session!!!

So I investigated and I find where the problem came from!

Well I think this happens only in few systems (if not only in this configuration): for test purposes I'm working locally with win98 and Activestate Perl.

I wondered that session are registered something like this:


hmmmm. columbus egg.
The problem is in the "-".

I just went to DB_Utils.pm and changed first lines of "sub authenticate" as here:
my $s = shift;
$s =~ /^[\d\w\-]+$/ | | return undef;
(length $s < 27) &#0124; &#0124; return undef;

that's it!

Another very important question.
What about Administratos (I'm talinks either about user sessions)? I tryed fo find some infos around but nothing.

Alex did you do any documentation on these new features?

bye bye

Quote Reply
Re: Editors Session Bug solved!! In reply to
How did that dash get in there? In your user.cgi around line 119 do you have:

($session = time . $$ . int (rand(16000)));