Gossamer Forum
Home : Products : Gossamer Links : PHP Front End :

some template problems

Quote Reply
some template problems
I've got my templates mostly converted over to the PHP and v2.x format, so I'm starting to get to being able to offer more informed feedback... :)

I'm getting the following warnings and errors:

[27-Jun-2002 18:10:48] PHP Warning: SAFE MODE Restriction in effect. The script whose uid is 41925 is not allowed to access /path/to/cgi-bin/links/admin/templates/default_php/compiled/globals.txt.php owned by uid 98 in /path/to/www/pages/PHP/Links.inc.php on line 351

[27-Jun-2002 18:10:48] PHP Warning: file("/path/to/cgi-bin/links/admin/templates/default_php/compiled/globals.txt.php") - Success in /path/to/www/pages/PHP/Links.inc.php on line 351

[27-Jun-2002 18:10:48] PHP Warning: Bad arguments to join() in /path/to/www/pages/PHP/Links.inc.php on line 351

[27-Jun-2002 18:10:48] PHP Parse error: parse error in /path/to/www/pages/PHP/Links.inc.php(353) : eval()'d code on line 1

As you can see, they happen at the same time when viewing a page, but I think there is more than one problem there. I would guess the last three are related to running phpAdsNew within the page (I had similar eval() incompatibilities with phpBB's template parser), but the safe mode error looks to be separate. I didn't see this brought up anywhere else in the PHP forum, but it looks like another reason why the PHP scripts should not be installed in the cgi-bin...

Any way around it short of moving the /Links/PHP/ directory and changing all the include paths?

An unrelated question: I've read that any PHP code should work just fine in the templates, but it appears global variables cannot be defined within functions in the templates. Is this correct?

Thanks,
Dan
Subject Author Views Date
Thread some template problems Dan Kaplan 9138 Jun 27, 2002, 4:33 PM
Thread Re: [Dan Kaplan] some template problems
brewt 9020 Jun 27, 2002, 5:01 PM
Thread Re: [brewt] some template problems
Dan Kaplan 8976 Jun 27, 2002, 5:25 PM
Thread Re: [Dan Kaplan] some template problems
brewt 9007 Jun 27, 2002, 6:12 PM
Post Re: [brewt] some template problems
Dan Kaplan 8982 Jun 27, 2002, 6:26 PM
Post Re: [brewt] some template problems
Dan Kaplan 8964 Jul 2, 2002, 5:02 PM
Thread Re: [brewt] some template problems
Dan Kaplan 8954 Jul 10, 2002, 9:41 AM
Thread welcome to Dan's chop shop...
Dan Kaplan 8925 Jul 15, 2002, 7:56 AM
Post Re: [Dan Kaplan] welcome to Dan's chop shop...
brewt 8904 Jul 18, 2002, 2:48 AM
Thread Re: [Dan Kaplan] some template problems
brewt 8945 Jul 18, 2002, 2:45 AM
Thread Re: [brewt] some template problems
Dan Kaplan 8879 Jul 18, 2002, 7:26 AM
Thread Re: [Dan Kaplan] some template problems
Dan Kaplan 8893 Jul 18, 2002, 7:46 AM
Post Re: [Dan Kaplan] some template problems
Dan Kaplan 8877 Jul 18, 2002, 9:18 AM
Post Re: [Dan Kaplan] some template problems
brewt 8915 Jul 18, 2002, 9:26 AM
Thread Re: [Dan Kaplan] some template problems
Alex 8903 Jul 18, 2002, 5:07 PM
Thread Re: [Alex] some template problems
Dan Kaplan 8886 Jul 18, 2002, 5:22 PM
Thread Re: [Dan Kaplan] some template problems
Alex 8862 Jul 18, 2002, 5:31 PM
Thread Re: [Alex] some template problems
Dan Kaplan 8877 Jul 18, 2002, 6:05 PM
Thread Re: [Dan Kaplan] some template problems
brewt 8924 Jul 18, 2002, 6:13 PM
Post Re: [brewt] some template problems
Dan Kaplan 8848 Jul 18, 2002, 6:26 PM
Thread Re: [brewt] some template problems
Dan Kaplan 8916 Jul 18, 2002, 6:54 PM
Thread Re: [Dan Kaplan] some template problems
brewt 8868 Jul 18, 2002, 9:21 PM
Thread Re: [brewt] some template problems
Dan Kaplan 8850 Jul 18, 2002, 9:33 PM
Thread Re: [Dan Kaplan] some template problems
shackman 8828 Jul 24, 2002, 8:33 AM
Post Re: [shackman] some template problems
Alex 2067 Jul 24, 2002, 9:48 AM
Thread Re: [Dan Kaplan] some template problems
Alex 2079 Jul 24, 2002, 9:54 AM
Post Re: [Alex] some template problems
Dan Kaplan 2065 Jul 24, 2002, 2:24 PM
Post Re: [Dan Kaplan] some template problems
Alex 8895 Jul 18, 2002, 6:15 PM