Gossamer Forum
Home : Products : Gossamer Links : Discussions :

t=template not working if category template?

Quote Reply
t=template not working if category template?
Hi,

I notived that if you use a custom template set in Category - then you are unable to pass t=newtemplate - is that a bug or is there a way around that?

What I want to do is to use a template2 for certain categories but also still have the option of calling a seperate template for a cobranded site - in other words if I use t=something it should use that instead of what is set in Category as template.

Any ideas?

Klaus

http://www.ameinfo.com
Quote Reply
Re: [klauslovgreen] t=template not working if category template? In reply to
hello,

when you add a custom template, it wil also want to use this custom template in other template sets.

I think it is good.
If this is not the case, the effect on using custom template sets will loose in in other template sets.
Quote Reply
Re: [ridesworld] t=template not working if category template? In reply to
Hi,

Maybe it is good in some cases - but I need to be able to overwrite it if I pass a template in the URL - anyone with a solution?

Merry X-Mas

Klaus

http://www.ameinfo.com
Quote Reply
Re: [klauslovgreen] t=template not working if category template? In reply to
A way to overwrite it maybe to add <%if Template%>&t=<%Template%><%endif%>

I'm not sure on the exact name thought. Try adding <%GT::Template::dump%> in subcategory.html, to see what the template tag is called.

Hope that helps Smile

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] t=template not working if category template? In reply to
Hi Andy,

It is called Category_Template - where should I insert the:

<%if Category_Template%>&t=<%Category_Template%><%endif%>

In the category.html or??

Klaus

http://www.ameinfo.com
Quote Reply
Re: [klauslovgreen] t=template not working if category template? In reply to
Just after the <%URL%> tag. i.e;

href="<%URL%><%if Category_Template%>&t=<%Category_Template%><%endif%>"

Then, if a template set is defined...it will hopefully pass it on Smile

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] t=template not working if category template? In reply to
Hi Andy,

The problem is not passing on the t=whatever, the problem is that if a Category_Template is set - then if I manually pass t=somethingelse in the url - it refuses to use that new template set and loads the one set in Category_Template

Cheers

Klaus

http://www.ameinfo.com
Quote Reply
Re: [klauslovgreen] t=template not working if category template? In reply to
What about passing &t=<%Template_Set%>

???

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] t=template not working if category template? In reply to
Hi Andy,

Thanks for your help - but same result Frown

Once the Category_Template is set I can't overwite it - whatever i insert in the URL is ignored...

Klaus

http://www.ameinfo.com
Quote Reply
Re: [klauslovgreen] t=template not working if category template? In reply to
You might need to edit the code, and reverse the check so that the check for t= comes after (or bypasses) the if category_template

I don't have access to my server from this machine, or I'd tell you where that is. I *think* it's in the Links.pm load_template call, but things got moved around a bit from version to version.

This might be something to look at changing in the next release, whether to allow "defined_template_override" ie: allow a t= switch to override a specifically defined template set.


PUGDOG´┐Ż Enterprises, Inc.

The best way to contact me is to NOT use Email.
Please leave a PM here.
Quote Reply
Re: [pugdog] t=template not working if category template? In reply to
Thanks - I'll find it :-)

On a second note - on Detalied pages Header and Footer info from the Category is not following - how do I load thr category info and use it on detailed pages as well?

I guess I need to pass the currrent category ID in the URL and then load category utils or something like that?

Klaus

http://www.ameinfo.com