Gossamer Forum
Home : Products : Gossamer Links : Discussions :

no matter how I try, I cant upgrade

Quote Reply
no matter how I try, I cant upgrade
Hello,

I've had this trouble in the past, and think I am covering the bases to make sure my files are uncompressed properly. Here's what happens: I download the new LSQL beta 3, which Alex said in his post was ok to upgrade to.

Stuffit Expander automatically unstuffs it into a .tar file. I then run Stuffit Expander again, and it unstuffs into a folder with the install.dat and the install.cgi files.

I upload them to the server, the dat file as binary, the cgi file as ascii

I then change permissions on the cgi file to be 755

I then run the cgi from my browser, choosing upgrade, give it the path to admin. It runs but stops after unpacking a portion of the files... it goes until:

Unarchiving (644) /big/dom/xcurvemag/www/content/images/fileman/toolbar/undo.gif

and then just stops.

What is ahppening here? Anyone know? I am on a mac. fyi.
Quote Reply
Re: [Evoir] no matter how I try, I cant upgrade In reply to
See:
http://www.gossamer-threads.com/...?post=175020;#175020
Try using the lite option as mentioned by Alex.
Remember, you shouldn't use the beta versions on production sites Smile

Adrian
Quote Reply
Re: [brewt] no matter how I try, I cant upgrade In reply to
Thanks. I'll give it a try. I have to re-upload the dat file Unimpressed

It's not a live site Wink but I am hoping to do some work on the templates and globals over the weekend. I've been working on this bugger for like 9 months now Smile I am a slow learner, but I am such a LSQL convert now.

I'll let you know how this turns out. I appreciate the help on a friday night.
Quote Reply
Re: [brewt] no matter how I try, I cant upgrade In reply to
nope. same thing. It all happens pretty fast, doesn't seem like a timeout.
Frown
Quote Reply
Re: [brewt] no matter how I try, I cant upgrade In reply to
Ok, so I went over to my virtual PC, re-downloaded in PC land from GT, unstuffed it (or whatever PC's call it) and then uploaded from the PC (dat in binary, cgi in ascii) and then checked file permissions.

Same thing. It stopped at:

Unarchiving (644) /big/dom/xcurvemag/www/content/images/fileman/toolbar/undo.gif

It doesn't seem likt a timeout, rather, it seems like a corrupted file, or uploaded the file wrong. But I can't figure it out. Ideas?
Quote Reply
Re: [Evoir] no matter how I try, I cant upgrade In reply to
Actually, it looks like undo.gif is the last file in the archive... so it's done unarching all the files.
Looking at install.cgi, it looks like after it's done unarching the files (in install()), it saves the config. Check to see if you have a ConfigData.pm in admin/Links. If you do then the install *probably* will work Smile. If all fails, you'll just have to wait for Alex to reply on this issue (but he's on his Perl Whirl trip so...)

Adrian
Quote Reply
Re: [Evoir] no matter how I try, I cant upgrade In reply to
This may be an odd question.... but are you running out of diskspace for some reason? I think most of the scripts assume there is disk space, and don't handle that error really well. (it's not one they expect to encounter in the larger scheme of things).

If the file was corrupted, it shouldn't run at all. I think the install script does a check before untaring, but either way, gzip would.

also, did you try taking your old aborted install, changing the name of the top directory, and reinstalling? If it's a disk problem, you've isolated the problem in the bad tree.

Just some thoughts.


PUGDOG´┐Ż Enterprises, Inc.

The best way to contact me is to NOT use Email.
Please leave a PM here.
Quote Reply
Re: [pugdog] no matter how I try, I cant upgrade In reply to
Well, it deletes the aborted installs .dat file and .cgi file. so I can't try re-installing, without re-uploading.

Also, I thought that maybe it was really fully installed, but when I am in the admin area, it does say: 2.10 beta 3, and it seems that most things do work, but when I go to build all, it gives an error:

Unable to open backup/ for writing: Is a directory at nph-build.cgi line 302.

Which makes me think that the install was not completed.

In the past, I had trouble with stuffit unarchiveing the files with a weird mac character at the end of a line (or something like that) but I had figurd that out and changed the settings. Also, unarchiving in PC and uploading from a PC would eliminate that as a problem.

Disk space: I ahve 131.71 MB avaialable in my shared server environment. Should be fine.
Quote Reply
Re: [brewt] no matter how I try, I cant upgrade In reply to
Still having trouble. Same thing. I get an error on trying to build.

I don't think the install was successful. I do see a ConfigData.pm dated today (I just tried to upgrade again.)

Is there a way to try a clean install, then link the MYSQL database to the clean install? I could try that.
Quote Reply
Re: [brewt] no matter how I try, I cant upgrade In reply to
nevermind. I downgraded. I'll wait for the full version Smile