Gossamer Forum
Home : Products : Gossamer Links : Discussions :

add.cgi problem

Quote Reply
add.cgi problem
I get an "...add.cgi script produces no output" error message after clicking on "add a link" after signing in as a user but all the other top row links work such as modify (says "oops, nothing to modify"), bookmark, new link etc.
I can add links fine from the admin area (as the administrator). I have checked my user templates and restored to original except for the include header and I've checked add.pm and some of the other .pm and cgi files and they look okay. Everything seems to be working except add.cgi (from user sign in )and this is this is the first time I've used it since installing 3.2. I"ve looked at build options and can't see anything that would cause this problem but we've never used "users" before as Goss was just used an "Internet Links" feature but now we want to enable people to upload media. Any suggestions to get this working would be greatly appreciated.
Quote Reply
Re: [shell] add.cgi problem In reply to

what version of IE do you use. I mention this not because I have a solution but I think I know what the problem may be.

If I have got it wrong I apologise in advance, nonetheless this is a problem.

In IE7 there is a IE7 Pro option under tools, having a look inside there is a ad filter which blocks loads of files such as ad.cgi files, somehow this is extending to add.cgi. I know this becuase my add page doesn't respond until I go into IE7 Pro and disable ad filtering. The killer is I think this is on by default for IE7 so it's going to be a big problem, no idea how long it's been like this cause I never test and add to my own directory although a search seems to show there isn't anyone else with the problem.



Quote Reply
Re: [KevM] add.cgi problem In reply to
Hi KevM,
thank you so much for your reply. I am not using IE 7 yet, I have 6.0.29 and I checked for a ad filter but didn't see one. I also checked Firefox but nothing obvious presented itself. Because I haven't used "users" before and have always worked from admin I can't tell if this is something to do with the script or with my computer settings. Below is the code on my add.cgi file. I'm not using payment, and so I don't have that enabled. I'm also wondering if permissions set on the server by my tech people could be affecting this. Has anyone else encountered this type of problem? Thanks, S

use strict;
use lib 'E:/its/wwwroot/cgi-script/glinks/admin';
use Links qw/$PLG/;
use Links::User::Add;

local $SIG{__DIE__} = \&Links::fatal;


if ($PLG->dispatch('check_request', \&Links::check_request)) {
$PLG->dispatch('handle_add', \&Links::User::Add::handle);
Quote Reply
Re: [shell] add.cgi problem In reply to
Hi, is there no where to view what the details of the sql tables? The forum is providing no help as I get 404 pages after the first pages of my latest searches.
My add.cgi is (as a user signing in from the site, it works within admin) is still not working and I'm thinking maybe it's connected to the only other thing that is not working, the email custom lists. The mass mailing options all seem to work.
I can modify a link that was created in admin and the user will get an email confirming that the link has been modified (though it does go to junk) and the link shows the modification. All user options work except the "add.cgi".

When I try to access the email custom lists though I get the following error messages:
Can't call method "fetchall_arrayref" on an undefined value at
E:/domain/wwwroot/cgi-script/glinks/admin/Links/MassMailer.pm line 804.
GT::SQL::error = Failed to execute query: 'SELECT ID,Name,DateCreated,DateModified FROM glinks_MailingListIndex':
Table 'glinks.glinks_mailinglistindex' doesn't exist
DBI::errstr = Table 'glinks.glinks_mailinglistindex' doesn't exist.
My sql database has the following two tables but NO glinks_mailinglistindex.

glinks_mailinglist and glinks_mailingindex

I have looked at all the relevant files and can't see anything that looks wrong. I also went on my old server and
was able to get lsql1 add.cgi to work properly. I can see on the old server that there is a table in this old sql database
named "lsql_mailinglistindex" but I haven't been able to look at the database as the server is not accessible from the web.
Does anyone know if this could be preventing add.cgi from working? With everything else working could it possibly be a permission issue?
I've been trying to eliminate this from the cause and since I can modify etc. I don't think this is the problem. Any help would be appreciated
as I've spent quite a bit of time on this and would rather not reinstall. Thank you.