Gossamer Forum
Home : Products : Gossamer Links : Discussions :

What Modules in Apache are needed to run Links SQL

Quote Reply
What Modules in Apache are needed to run Links SQL
Hi:

I have a messed up server.... and I REALLY do not know what to do. I am thinking I do not have all the required modules installed in Apache, or that one that is installed is installed wrong, and needs to be re-installed.

here is the error message I am getting:

/usr/libexec/ld-elf.so.1:
/usr/local/lib/perl5/site_perl/5.005/i386-freebsd/auto/DBD/mysql/mysql.so: Undefined symbol
"mysql_num_rows"

So, my question is, from this error, can anyone tell what is missing or messed up. Being VERY new to Unix and Apache, please be verbose if you have a solution!

Second question, what modules do I need? GT says only: Perl database modules: DBI and the appropriate DBD module loaded... what are those "appropriate" modules? (As there are 100's of those darn modules, again, please be as specific as possible.... not just DBD modules, but WHICH DBD modules..)

Here is what I have installed now:

apache+mod_ssl-1.3.14+2.7.1_1 The Apache 1.3 webserver with SSL/TLS functionality
apache-1.3.14 The extremely popular Apache http server. Very fast, very c
bash-2.04 The GNU Borne Again Shell
emacs-20.7 GNU editing macros
emacs-dl-20.7 GNU editing macros with dynamic loading module function (bin
freetype-1.3.1 A free and portable TrueType font rendering engine
gd-1.8.3 A graphics library for fast PNG creation
gettext-0.10.35 GNU gettext package
gmake-3.79.1 GNU version of 'make' utility
jpeg-6b IJG's jpeg compression utilities
libiodbc-2.50.3 ODBC library, for universal database access
libtool-1.3.4_1 Generic shared library support script
libwww-5.3.1 The W3C Reference Library
mm-1.1.3 Shared memory library for applications with pre-forked proce
mod_perl-1.24 Embeds a Perl interpreter in the Apache server
mysql-client-3.22.32 Multithreaded SQL database (client)
mysql-client-3.23.26 Multithreaded SQL database (client)
ncftp1-1.9.5 FTP replacement with advanced user interface
p5-Apache-1.24 Embeds a Perl interpreter in the Apache server
p5-Apache-DBI-0.87 DBI persistent connection, authentication and authorization
p5-DBI-1.14 The perl5 Database Interface. Required for DBD::* modules
p5-Data-ShowTable-3.3 Perl5 module to pretty-print arrays of data
p5-Mysql-modules-1.2215 Perl5 modules for accessing MySQL databases
p5-Net-Daemon-0.31 Perl5 extension for portable daemons
p5-SQL-Statement-0.1016 A perl5 module for SQL parsing and processing
p5-Storable-1.0.5 Persistency for perl data structures
p5-Text-CSV_XS-0.20 Composition and decomposition of comma-separated values
p5-libwww-5.48 Perl5 library for WWW access
png-1.0.8_1 Library for manipulating PNG images
sendmail-8.11.1 Reliable, highly configurable mail transfer agent with assoc
tcl-8.3.1 Tool Command Language

Am I missing anything important?

Thanks.... Oh, and I know this is more of an apache question that Links.... but the Apache DOES work, and Links does not, so I thought I would post here...

dave

Subject Author Views Date
Thread What Modules in Apache are needed to run Links SQL carfac 1580 May 4, 2001, 8:15 PM
Thread Re: What Modules in Apache are needed to run Links SQL
carfac 1513 May 5, 2001, 12:07 PM
Post Re: What Modules in Apache are needed to run Links SQL
carfac 1538 May 5, 2001, 2:13 PM
Thread Re: What Modules in Apache are needed to run Links SQL
pugdog 1507 May 5, 2001, 8:48 PM
Post Re: What Modules in Apache are needed to run Links SQL
carfac 1507 May 5, 2001, 9:18 PM