Gossamer Forum
Home : Products : Gossamer Links : Discussions :

Strange things when using dynamic

Quote Reply
Strange things when using dynamic
What's going on here when calling my site dynamically? (errors)

I call the index page:
Unable to find detailed page: ''.

I call the Cool page:
Category 'Cool' does not exist.

I call the New page:
Category 'New' does not exist.

I call the Ratings page:
Category 'Ratings' does not exist.

Any ideas?

--------------------------------
Privacy Software
Quote Reply
Re: [BLOOD] Strange things when using dynamic In reply to
Are your paths correct? Are you using rewrite rules to generate static URLs with a dynamic site?
Quote Reply
Re: [aus_dave] Strange things when using dynamic In reply to
Hi thanks,

I have no rewrite rules in operation.

I see the problem now -- either I'm not doing this right or itís a bug.

I have the detailed pages at:

site.com/cars/ford-escort.html
site.com/vans/treo.html
etc.

build_category_format: Full/Long Category/Name
build_detail_format: Advanced: %Full_Name%/%Title%

AND

build_detail_url: site.com

And their's the problem. If I set build_detail_url to a directory other than the root such as Detailed then I get no errors BUT the categories are then built as:

site.com/Detailed/cars/ford-escort.html
site.com/Detailed/vans/treo.html

Which is not what I want. It seems you HAVE to set a directory for detailed pages else it wont work in dynamic mode :(

--------------------------------
Privacy Software

Last edited by:

BLOOD: Apr 27, 2006, 2:15 PM
Quote Reply
Re: [BLOOD] Strange things when using dynamic In reply to
Are you using Pugdog's detailed pages plugin? Combined with mod_rewrite rules it it gives you a lot of flexibilty in how you structure your site and how the URLs appear.