Gossamer Forum
Home : Products : Gossamer Links : Discussions :


Quote Reply
I seem to have some permissions issues.

I deleted all directories and files by FTP and then rebuilt the whole directory.

Although I can access the directory home page, when I click on a category I get: "Internal Server Error"

The error log shows:

[error] ... SoftException in Application.cpp:261: File "/home/xnet/public_html/links/Blogging/index.htm" is writeable by group
[error] ... SoftException in Application.cpp:631: Directory "/home/xnet/public_html/links/Blogging" is writeable by group

I had made no changes to file permissions when this happened.

In setup build_dir_per was 0777 and build_file_per was 0666.

I have tried changing file permissions to everything imaginable but no difference.

The backend is working fine, the directory runs in dynamic ok, the pages have all been built (I can download them by FTP and open in a browser).

Any ideas please?Crazy

Quote Reply
Re: [iplay] Permissions In reply to

Who are the files owned by? If you have SSH, try doing:

cd /path/to/public_html
ls -lh

...and then message me the output (you probably don't want to put it on a public forum - although not sure if anyone could do anything with it :))


Andy (mod)
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Permissions In reply to
Just to update this thread, the problem turned out to be simply that build_dir_per was 0777 but for this server it needed to be 0755—and for some reason I had been unable to update it through the GT backend. It kept reverting to 0777. Andy fixed it through SSH (thanks Andy).