Gossamer Forum
Home : Products : Gossamer Links : Discussions :

Install Problems.

Quote Reply
Install Problems.
I am having trouble with the Links SQL 2 installation form. I wanted GT to install the script so I would avoid any problems with permissions, spelling and punctuation errors.

I set up a second account with my host. I did this so that the installation of Links SQL, the creation of the new Links SQL based site and any related changes would not disrupt the operation of the existing site.

The "new" site has a unique IP (different from the "old" site IP), and I have used ftp to set up the pages and cgi-bin/links2 directories. I have set the permissions on the /pages folder to 777.

The problem appears to be that the DNS point to the "old" site and when the Links SQL install program checks paths, it is finding the "old" site.

I have also tried using the "new" site IP numbers in the page URL box, but I still the the path error message.

Anyway, I get an error message about the /pages path when I try to fill out the online installation form.

Is there a way around this?

Quote Reply
Re: Install Problems. In reply to

Make sure you are entering a PATH, not a URL in the setup box. If you place the install.cgi and install.dat files into the cgi-bin/links2 directory, the defaults should be ok. The only changes will be to the pages url and pages directory.



Gossamer Threads Inc.
Quote Reply
Re: Install Problems. In reply to
Changing to the IP number solved that.

I also found out ftp won't reliable change permissions on folders. I had to use telnet to chmod 777 pages/

I am now getting the following error message when I press the verify button:

The following errors occured while checking the mysql components:
Connection failed:
Access denied for user: 'myname@localhost' (Using password: YES)

To have us install anyways, we will need the root password,
or contact your ISP to have the mysql stuff setup and rerun this script.

I am not sure exactly what this means, but I have forwarded on to my host's support email address. (It does mean I am getting further before I encounter an error message :-)