Gossamer Forum
Home : Products : Gossamer Links : Discussions :

How to fix a login bug

Quote Reply
How to fix a login bug
Recently I found a bug in the Links SQL 2.1. I didn't notice it before but now since I redesigned the layout of the site I see some strange behavior and I don't know how to fix it. The problem is when user goes to the login screen he has to enter his username and a password but if user enters only his user name and hits Login button, the logout link appears, even though user has not been authenticated by the system yet. It's is very inconvenient because it's revealing the next step of the authentication process. I assume by looking at the code that it happens because of the tag

<%if Username%>Logout<%endif%>
<%ifnot Username%>Login<%endif%>

Based on the logic of the code, anyone who enters anything in the username text box and hits Login button will see the link surrounded by the first pair of tags because Username variable is not empty and hence the first statement is true. Does anyone know how to fix this problem?




Subject Author Views Date
Thread How to fix a login bug bob1980 1549 Oct 1, 2004, 2:53 PM
Thread Re: [bob1980] How to fix a login bug
pugdog 1500 Oct 1, 2004, 4:29 PM
Thread Re: [pugdog] How to fix a login bug
bob1980 1498 Oct 1, 2004, 5:04 PM
Thread Re: [bob1980] How to fix a login bug
pugdog 1469 Oct 2, 2004, 5:38 AM
Thread Re: [pugdog] How to fix a login bug
bob1980 1475 Oct 2, 2004, 11:13 AM
Thread Re: [bob1980] How to fix a login bug
pugdog 1478 Oct 2, 2004, 4:06 PM
Post Re: [pugdog] How to fix a login bug
bob1980 1418 Oct 6, 2004, 4:42 PM