Gossamer Forum
Home : Products : Gossamer Links : Discussions :

Can't locate object method "protocol_version" via package "GT::SQL::Driver::MYSQL"

Quote Reply
Can't locate object method "protocol_version" via package "GT::SQL::Driver::MYSQL"
Anyone seen this before?

Can't locate object method "protocol_version" via package "GT::SQL::Driver::MYSQL"

Its in admin area. Is it a perl module missing?
Quote Reply
Re: [areh] Can't locate object method "protocol_version" via package "GT::SQL::Driver::MYSQL" In reply to
Sounds like you have conflicting versions of libraries loaded. Are you using community? If so, you'll need to upgrade it to the latest version. If you're using mod_perl, make sure the use lib is in the correct order (newest program to oldest).

Adrian
Quote Reply
Re: [brewt] Can't locate object method "protocol_version" via package "GT::SQL::Driver::MYSQL" In reply to
No, Im not using Community, not mod_perl either. But I do use Speedy. Ill try to switch to normal perl and see what happens then.
Quote Reply
Re: [areh] Can't locate object method "protocol_version" via package "GT::SQL::Driver::MYSQL" In reply to
For some reason, that fixed it.