Gossamer Forum
Home : Products : Gossamer Links : Discussions :

Bareword not allowed while strict subs in use

Quote Reply
Bareword not allowed while strict subs in use

A couple users of my CAPTCHA plugin have complained of the following error.
This error is on installation of the plugin, and it fails to install.

Unable to load plugin: CAPTCHA (Bareword "GT::Date::FORMAT_DATETIME" not
allowed while "strict subs" in use at
/var/www/cgi-bin/admin/Plugins/CAPTCHA.pm line 526.

Compilation failed in require at admin.cgi line 204.
) at admin.cgi line 206

The code at line 526 is:
$input->{Review_Date} = GT::Date::date_get(time, GT::Date::FORMAT_DATETIME);

One of the users said they were able to get it to install, but they had to comment out
the 'use strict' line at the top of the plugin's .pm file. Additionally they said...
Fixed the install problem, had to change the owner of everything to www since apache was running in safe mode.

How do I fix the error for my clients?
I don't think commenting out 'use strict' was the correct solution.

Plenty of users install this plugin without any problems. It is only a couple who have
had an issue, and they both had this exact SAME error above.


PS sorry this should have gone in plugins Forum Unsure
RGB World, Inc. - Software & Web Development.

Last edited by:

rgbworld: Jan 16, 2007, 9:35 PM
Quote Reply
Re: [rgbworld] Bareword not allowed while strict subs in use In reply to
GT::Date::FORMAT_DATETIME was added in glinks 3.2, so if you're using that in your code, they'll get that error unless they're using 3.2. In some cases, you can still get that error if they're using an older version of Community (if they upgrade community, it should fix that problem).