Gossamer Forum
Home : Products : Gossamer Links : Development, Plugins and Globals :

Spider Error: Unable to load plugin

Quote Reply
Spider Error: Unable to load plugin

I tried to install Gossamer Spider Plug in without success some time ago

I moved my web to a new dedicated server, and I did reinstall Gossamer succesfully on my new Server
But I let the unsuccesfull instalation of Spider just like it was in my other server, and I am triying again to make it work

I tried to uninstall it, but it dont let me do it

I tried to modify it, to make it work, but I can't

If in Gossamer Links Admin, I go to my Plug Ins, at the end, it says the following:

Unable to load plugin 'Spider': Install.pm does not compile: Illegal declaration of subroutine Plugins::Spider::force_Spider1 at (eval 7) line 405.

At line 405 I found:
sub force_Spider1.0 {
# -------------------------------------------------------------------
# forces the spider tables from Spider1.0 to Spider2.0

Any Idea, how can I Fix this error?

Quote Reply
Re: [tenoch] Spider Error: Unable to load plugin In reply to
I would think to remove the period and zero (.0) from the subroutine name,
but it is not my plugin, so do it with caution because all calls to that
subroutine would need to be changed as well.

RGB World, Inc. - Software & Web Development.