Gossamer Forum
Home : Products : Gossamer Links : Development, Plugins and Globals :

Problem code validation of user registry

Quote Reply
Problem code validation of user registry
When I add the code validation of user registry, it does not show the confirmation page, (it shows an empty page without no error or HTML) nevertheless it registers the code of validation of the user successful.

You can say to me, as can be the reason of this? (user.cgi)

Regards,

Gilberto Balza
Quote Reply
Re: [venezuelasite] Problem code validation of user registry In reply to
Have you checked the success template is not empty, or has invalid code that would stop it showing in your browser?

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Problem code validation of user registry In reply to
Thanks Andy, But these pages still I not modified the code (validate_form.html and validate_success.html). They are in the orginal format of the package in Spanish.

validate_form.html

<%--
Archivo : validate_form.html
Descripcion : Este template es usado cuando un usuario esta validando su cuenta.
Etiquetas : La unica etiqueta (tag) especial es:
error => Un mensaje diciendo que la cuenta no pudo ser validada.

--%>
<html>

<head>
<title><%site_title%>: Validacion</title>
<%css%>
</head>

<%body_tag%>
<center>
<%include include_header.html%>
<%body_table%>
<tr><td align=center>
<%include include_menu.html%><br><%include include_search_bar.html%>
</td></tr>
<tr><td align=center>

<table border=0 width="100%" cellpadding=0 cellspacing=0>
<tr><td bgcolor=black width=6>
<img src="<%build_images_url%>/default/ClearShim.gif" width=6 height="200"></td>
<td valign=top>

<table border=0 width="100%" cellpadding=3 cellspacing=0>
<%header_row%><td width="30%">
<%header_font%>VALIDACION<%/header_font%></td>
<td bgcolor=white width="70%">&nbsp;</td></tr>
<tr><td colspan=2 align=center valign=middle>

<form action="<%db_cgi_url%>/user.cgi" method="POST">
<input type=hidden name=validate_user value=1>
<table border ="0" cellspacing="0" cellpadding="4">
<tr><td colspan=2>
<%if error%>
<p><%error_font%><b><%error%></b></font></p>
<%endif%>
<%body_font%>
Para Validar su cuenta, favor de insertar el codigo del cual fue provisto:</font></td></tr>
<tr><td align="right" valign="top"><%body_font%>Codigo:</font></td>
<td><input name="code" size="50"></td></tr>
<tr><td></td><td><%body_font%>
<input type="SUBMIT" name="validate_user" value="Validate"></font></td></tr>
</table>
</form>
</td></tr></table>

<tr><td colspan=2>
<img src="<%build_images_url%>/default/BlackShim.gif" border=0 height=1 width="<%body_width%>" align=top>
<%include include_menu.html%>
</td></tr>
</table> </td></tr></table>
<%include include_footer.html%>
</center>
</body>
</html>

validate_success.html

<%--
Archivo : validate_success.html
Descripcion : Este archivo se muestra despues de que un usuario a validado exitosamente su cuenta
Etiquetas : Todas las propiedades del usuario estan disponibles en esta pagina.

<html>
<head>
<title><%site_title%>Cuenta Activada</title>
<%css%>
</head>

<%body_tag%>
<center>
<%include include_header.html%>
<%body_table%>
<tr><td align=center>
<%include include_menu.html%><br><%include include_search_bar.html%>
</td></tr>
<tr><td align=center>

<table border=0 width="100%" cellpadding=0 cellspacing=0>
<tr><td bgcolor=black width=6 rowspan=2>
<img src="<%build_images_url%>/default/ClearShim.gif" width=6 height="200"></td>
<td>

<table border=0 width="100%" cellpadding=3 cellspacing=0>
<%header_row%><td width="30%">
<%header_font%>CUENTA ACTIVADA<%/header_font%></td>
<td bgcolor=white width="70%">&nbsp;</td></tr>
<tr><td colspan=2 align=center>

<%body_font%>Gracias, Su cuenta ha sido Activada!</font>
<br><br><br>&nbsp;

</td></tr></table>

<tr><td>
<img src="<%build_images_url%>/default/BlackShim.gif" border=0 height=1 width="<%body_width%>" align=top>
<%include include_menu.html%>
</td></tr>
</table>
<%include include_footer.html%>
</center>
</body>
</html>
Quote Reply
Re: [venezuelasite] Problem code validation of user registry In reply to
Gilberto,
I'm afraid you use "user registry" in wrong context. The "user registry" expression has a special meaning in Links SQL, which means a special area in the plugin config. Please try to avoid this expression to avoid misunderstandings if possible.
Preferrably use "registered users", or "user table" instead of it.

1) Could you turn on debugging, so we could know more what happens in the background?
2) Do you use the default template set?
3) Also do you have any plugins installed?
4) Did you try to uninstall all plugins?
5) Do you have GCommunity installed?
6) Do you use Windows or Unix?

Just a few questions at the beginning Wink

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Quote Reply
Re: [webmaster33] Problem code validation of user registry In reply to
In Reply To:
Gilberto,
I'm afraid you use "user registry" in wrong context. The "user registry" expression has a special meaning in Links SQL, which means a special area in the plugin config. Please try to avoid this expression to avoid misunderstandings if possible.
Preferrably use "registered users", or "user table" instead of it.

Sorry Crazy , you can see my English is very very bad, in the future I will try to use the correct expressions in this forum.

1) Could you turn on debugging, so we could know more what happens in the background?
I have changed at this moment debug_level 1

2) Do you use the default template set?
Yes, of course I am making change only of graphical design

3) Also do you have any plugins installed?
Not yet, we are finishing front end user

4) Did you try to uninstall all plugins?
No

5) Do you have GCommunity installed?
┐?

6) Do you use Windows or Unix?
Unix - Linux - Red Hat 7.0

Just a few questions at the beginning Wink
Quote Reply
Re: [venezuelasite] Problem code validation of user registry In reply to
Could you post the debug messages from success page?

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Quote Reply
Re: [webmaster33] Problem code validation of user registry In reply to
Still it shows the empty page, Nevertheless you can see the content of error.log of Apache

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT * FROM lsql_Users WHERE Validation = 10508598203227294 from Links::User::Login::validate_user at /www/htdocs/venezuelasite/home/cgi-bin/admin/Links/User/Login.pm line 214

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT Username,Status FROM lsql_Users WHERE Username = 'tony' from Links::User::Login::validate_user at /www/htdocs/venezuelasite/home/cgi-bin/admin/Links/User/Login.pm line 222

GT::SQL::Driver::MYSQL::sth (9308): Executing query: UPDATE lsql_Users SET Status = 'Registered' WHERE Username = 'tony' from Links::User::Login::validate_user at /www/htdocs/venezuelasite/home/cgi-bin/admin/Links/User/Login.pm line 222

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT Username FROM lsql_Users WHERE Username = 'tony' AND Password = 123 from Links::Authenticate::auth_valid_user at /www/htdocs/venezuelasite/home/cgi-bin/admin/Links/Authenticate.pm line 70

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT * FROM lsql_Users WHERE ( Username = 'tony' ) from Links::Authenticate::auth_get_user at /www/htdocs/venezuelasite/home/cgi-bin/admin/Links/Authenticate.pm line 113

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT COUNT(*) FROM lsql_Sessions WHERE session_id = '18b7a2c7155f11f8f3b1bd8b2c73d312' from GT::Session::SQL::new at /www/htdocs/venezuelasite/home/cgi-bin/admin/GT/Session/SQL.pm line 96

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT * FROM lsql_Sessions WHERE ( ( session_date < 1050849073 ) ) from GT::Session::SQL::cleanup at /www/htdocs/venezuelasite/home/cgi-bin/admin/GT/Session/SQL.pm line 263

GT::SQL::Driver::MYSQL::sth (9308): Executing query: DELETE FROM lsql_Sessions WHERE ( session_date< 1050849073 ) from GT::Session::SQL::cleanup at /www/htdocs/venezuelasite/home/cgi-bin/admin/GT/Session/SQL.pm line 263

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT COUNT(*) FROM lsql_Sessions WHERE session_id = '18b7a2c7155f11f8f3b1bd8b2c73d312' from GT::Session::SQL::save at /www/htdocs/venezuelasite/home/cgi-bin/admin/GT/Session/SQL.pm line 204

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT COUNT(*) FROM lsql_Sessions WHERE session_id = '18b7a2c7155f11f8f3b1bd8b2c73d312' from GT::Session::SQL::save at /www/htdocs/venezuelasite/home/cgi-bin/admin/GT/Session/SQL.pm line 212

GT::SQL::Driver::MYSQL::sth (9308): Executing query: INSERT INTO lsql_Sessions (session_user_id,session_date,session_id,session_data) VALUES ('tony',1050859873,'18b7a2c7155f11f8f3b1bd8b2c73d312','{\'d\',\'1\',\'sessions\',\'Cookies\'};') from GT::Session::SQL::save at /www/htdocs/venezuelasite/home/cgi-bin/admin/GT/Session/SQL.pm line 212

GT::Session::SQL (9308): Session '18b7a2c7155f11f8f3b1bd8b2c73d312' created and saved. at /www/htdocs/venezuelasite/home/cgi-bin/admin/GT/Session/SQL.pm line 213.

GT::SQL::Driver::MYSQL::sth (9308): Executing query: SELECT * FROM lsql_Users WHERE ( Username = 'tony' ) from Links::Authenticate::auth_get_user at /www/htdocs/venezuelasite/home/cgi-bin/admin/Links/Authenticate.pm line 113
Quote Reply
Re: [venezuelasite] Problem code validation of user registry In reply to
Hmmm. I don't see any problem in debug log.
I'm almost out of ideas. Everything seems fine until now (at least for me).

1) Could you check the html source of success page? What is in it?
2) Could you try out this?: in Admin/Setup/Misc Options/ temporarily turn nph_headers option to the other. If was YES, turn to NO. Sometimes this helps in header problems.
If you tried out the validation, turn this back to original state!
3) check that language.txt and globals.txt are syntactically correct, in you template dir you currently use.
perl -c language.txt
perl -c globals.txt

My supposed problem origin can be:
a) somehow a file has been corrupted, or a core file somehow got a got a syntax error
b) header problem (printed incorrectly, or your system has a cgi wrapper installed)

I have no more idea.

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Quote Reply
Re: [webmaster33] Problem code validation of user registry In reply to
I have made everything what you say to me and even so persists the problem, I will try later with my clear mind and I will fix the problem I will be writing to you.

Thank you.
Quote Reply
Re: [venezuelasite] Problem code validation of user registry In reply to
Did you try looking at it in a different browser?

Remove the <%css%> tag and try.

I'm blanking on the #1 problem for returned blank pages, (no pun intended) and tried to search for how it was handled before. Maybe someone can remember -- it was fairly recently discussed. It was a tag, a plugin, a bad header, or something like that. (Nothing is triggering the memory... <sigh>)


PUGDOG´┐Ż Enterprises, Inc.

The best way to contact me is to NOT use Email.
Please leave a PM here.
Quote Reply
Re: [pugdog] Problem code validation of user registry In reply to
In Reply To:
Did you try looking at it in a different browser?
Yes, Internet Explorer and Netscape

Remove the <%css%> tag and try.
Ready, but it continues showing the empty page

I'm blanking on the #1 problem for returned blank pages, (no pun intended) and tried to search for how it was handled before. Maybe someone can remember -- it was fairly recently discussed. It was a tag, a plugin, a bad header, or something like that. (Nothing is triggering the memory... <sigh>
OK I will investigate a little more. Nevertheless it will continue being in my list of "things to do"
Quote Reply
Re: [pugdog] Problem code validation of user registry In reply to
Pugdog:

>>> I'm blanking on the #1 problem for returned blank pages

I have had this happen, and it is usually (for me!) messing around with site_html.pm or build.pm. That does NOT seem to be the case here.

I assume this is the ONLY page effected Venzuela? And it is a STRAIGHT install with absolutely NO modifications or Plug-Ins (except for editing templetes)?

If that is the case, I would go back to the original English toally unedited signin-sucess.html templete and see what happens.

Sorry, not too much help...
dave

Big Cartoon DataBase
Big Comic Book DataBase