Gossamer Forum
Home : Products : Gossamer Links : Development, Plugins and Globals :

Plugin pre auth_valid_session..

Quote Reply
Plugin pre auth_valid_session..
For some reason, in one of my plugins...when you run it via SSH, you get the following error message;

GT::Plugins (27046): Plugin pre auth_valid_session stopped further plugins. at /home/ameinfo/ameinfo.com/cgi-bin/events/admin/GT/Plugins.pm line 99.

This ia a bit weird...cos I don't call auth_valid_session, I simply include Links::Plugins.

Why would I get this error, if I havn't even included this function?

The headers look like;

Code:
#!/usr/local/bin/perl
# ==================================================================
# Links SQL - enhanced directory management system
#
# Website : http://gossamer-threads.com/
# Support : http://gossamer-threads.com/scripts/support/
# CVS Info : 087,070,093,092,086
# Revision : update_days.cgi v 2.0
#
# Copyright (c) 2002 Gossamer Threads Inc. All Rights Reserved.
# Redistribution in part or in whole strictly prohibited. Please
# see LICENSE file for full details.
# ==================================================================
# Plugin developed by Andy Newby from http://www.ace-installer.com.
# THIS IS NOT A FREE PLUGIN!
# ==================================================================

use strict;
use lib '/path/to/admin';
use Links qw/$IN $DB $CFG $USER/;
use GT::SQL;
use GT::Date;
use Links::Plugins;
use CGI::Carp qw(fatalsToBrowser);
my $debug = 0;

local $SIG{__DIE__} = \&Links::fatal;

Links::init();
Links::init_user('/path/to/admin');

Any ideas are appreciated :/

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Plugin pre auth_valid_session.. In reply to
Also, my test copy is on v2.1.1, whilst the problem copy if running on v2.1.2. Were any changes made, that would cause an error to show in 2.1.2, but not 2.1.1? Unsure

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Plugin pre auth_valid_session.. In reply to
Might be Community...

Ivan
-----
Iyengar Yoga Resources / GT Plugins
Quote Reply
Re: [yogi] Plugin pre auth_valid_session.. In reply to
Damn...your right I think Frown

Auth_Community 1.0.0 Gossamer Threads Inc. Edit | Uninstall

What version is the least buggy?

Cheers

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Plugin pre auth_valid_session.. In reply to
No... it's in *every* version of the .pm in all GT programs. I had to edit 3 different files, in Links, Gforum and COmmunity to get rid of it. Look at the path-to-file, to see which program. I kept swatting it, but didn't look at the path, and didn't realize it was in all released programs!

Alex is now aware of this, and it's a change to 2 lines of code in the base module, and it *should* be gone from future releases ;)


PUGDOG´┐Ż Enterprises, Inc.

The best way to contact me is to NOT use Email.
Please leave a PM here.
Quote Reply
Re: [pugdog] Plugin pre auth_valid_session.. In reply to
Quote:
and it *should* be gone from future releases ;)

It is. =)

Cheers,

Alex
--
Gossamer Threads Inc.
Quote Reply
Re: [Alex] Plugin pre auth_valid_session.. In reply to
Thanks guys Smile

Andy (mod)
andy@ultranerds.co.uk
Want to give me something back for my help? Please see my Amazon Wish List
GLinks ULTRA Package | GLinks ULTRA Package PRO
Links SQL Plugins | Website Design and SEO | UltraNerds | ULTRAGLobals Plugin | Pre-Made Template Sets | FREE GLinks Plugins!
Quote Reply
Re: [Andy] Plugin pre auth_valid_session.. In reply to
I have the latest Links and Comm, and I am still getting this....

what do I need to change to get this out of my error log?
dave

Big Cartoon DataBase
Big Comic Book DataBase
Quote Reply
Re: [carfac] Plugin pre auth_valid_session.. In reply to
Got rid of it by commenting out two lines in GT/Plugins.pm.... but I can't think that is a good thing to do. I checked, it IS the latest code for plugins.pm AND the GComm plug-in.... Unimpressed
dave

Big Cartoon DataBase
Big Comic Book DataBase