Gossamer Forum
Home : Products : Gossamer Links : Development, Plugins and Globals :

[fix] Bareword "PERSIST" not allowed while "strict subs"

Quote Reply
[fix] Bareword "PERSIST" not allowed while "strict subs"
I got following errors, into my error log (the fix solution is described at the end of the post):
Quote:
Bareword "PERSIST" not allowed while "strict subs" in use at C:/Work/site/cgi-bin/lsql/admin/GT/Config.pm line 307.
Bareword "PERSIST" not allowed while "strict subs" in use at C:/Work/site/cgi-bin/lsql/admin/GT/Config.pm line 345.
Compilation failed in require at C:/Work/site/cgi-bin/lsql/admin/Links.pm line 31.
Links SQL version used: v2.2.1

The GT/Config.pm (Config.pm v1.43, Links SQL v2.2.1) contains this code at line 307:
Code:
my $just_do_ok = not (PERSIST or $att->{inheritance} or $att->{local} or $att->{create_ok});

Fix solution:
The problem got solved easily, because I found that there was an old GT library directory in one of the library paths used (@INC).
So if you have similar problem, you should look around in your directories, if do you have a copy of the GT directory available somewhere in your appication paths.

Of course this is just one (rare) solution for this problem.
There can be also other problems, like you have different GT application versions installed, which uses different GT library versions. Usually the solution is to upgrade all your used GT applications to latest one.


I posted this error and the solution as reference for those, who get similar error and searching
the GT Forum can find this solution.
I hope this post will help some people in future.

Best regards,
Webmaster33


Paid Support
from Webmaster33. Expert in Perl programming & Gossamer Threads applications. (click here for prices)
Webmaster33's products (upd.2004.09.26) | Private message | Contact me | Was my post helpful? Donate my help...
Subject Author Views Date
Post [fix] Bareword "PERSIST" not allowed while "strict subs" webmaster33 1257 Feb 27, 2005, 8:26 PM