Gossamer Forum
Home : Products : DBMan SQL : Discussion :

DBManSQL on Localhost

Quote Reply
DBManSQL on Localhost
Hi,

I recently installed Apache2 (plus ActivePerl, MySQL, PHP) on my WinXP system. I then installed DBManSQL (little tricky but seems to work OK). Smile

I did this for two reasons -

1/ So I can use INNODB tables (my current host doesn't support them),

2/ So I can test everything offline.

I was just wondering if anyone else has tried it on a local sever and how it's running?

Thanks.

Simon.
Quote Reply
Re: [jai] DBManSQL on Localhost In reply to
Can someone give detailed instructions on how to set this up on a local machine for offline testing purposes?

TIA
Quote Reply
Re: [donm] DBManSQL on Localhost In reply to
How far have you got so far?
Have you installed Apache, ActivePerl, MySQL, etc. or are you starting from scratch?
Simon.
Quote Reply
Re: [jai] DBManSQL on Localhost In reply to
Starting from scratch

Thanks!
Quote Reply
Re: [donm] DBManSQL on Localhost In reply to
I did this sometime ago and got it to work but I'm not sure how relevant it will be now. Following are my own notes that should steer you in the right direction (although I don't know if all the links will still be valid).

Installing Local Server
My System:
Win XP Pro/Apache 2.0.47/Active Perl 5.8/MySQL 4.0/PHP 4.3.

Installed Files:
apache_2.0.47-win32-x86-no_ssl.msi
http://ring.asahi-net.or.jp/...2.0.47-win32-src.zip

Reference 1: http://www.mattjacob.org/server/index.html
(Donft use the versions they say, get the latest ones)
Reference 2: http://www.devshed.com/...ySeamless/page1.html
(May not be 100% applicable but useful anyway).
Apache 2 Installation
Download - apache_2.0.47-win32-x86-no_ssl.msi
http://ring.asahi-net.or.jp/...2.0.47-win32-src.zip

Install Apache 2 to H:/Apache (after installation it will end up as H:/Apache/Apache2)
Follow the propts -
Network Domain: 127.0.0.1
Server Name: localhost
Administratorfs Email:
Check for ALL users, on port 80, as a service (recommended)
Setup Type: Typical
Finish
Open Browser and call up http://127.0.0.1 or http://localhost/
If you can see the Apache test page then everything is ok.
If there is a copy of index.html in the H:\httpdocs then that page will be displayed.

Troubleshooting:
If there is a problem with the service and itfs not installed or disabled.
First, check under Services and see if Apache Service is installed and running.
If it is not installed, manually install it from Command Prompt:
Adjust the address to suit
"C:\Program Files\Apache Group\Apache2\bin\apache" -k install -n "Apache2"
Restart computer.

ActivePerl-5.8.0.806-MSWin32-x86.msi
http://downloads.activestate.com/...5.8/AP806_source.zip

Active Perl Installation
Download - ActivePerl-5.8.0.806-MSWin32-x86.msi
http://downloads.activestate.com/...5.8/AP806_source.zip
Install into H:/usr directory
Make sure there is a copy of hello.cgi in the httpdocs directory and call it up using - http://127.0.0.1/hello.cgi or http://localhost/hello.cgi
If you see gHello, worldh everything is ok.

If you get a Forbiden Error add the following to httpd.conf after the ScriptAlias section below -
#ScriptAlias /cgi-bin/ "H:/Apache2/cgi-bin/"

#
# "H:/Apache2/cgi-bin" should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.
#
<Directory "H:/Apache2/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

Add this -
##Added the following so the script is accessable (DON"T KNOW WHY WE NEEDED TO DO THIS)
<Directory "H:/httpdocs">
Options +ExecCGI
</Directory>
#end


Restart Apache and it should work.


mysql-4.0.15-win.zip
http://www.mysql.com/....zip&pick=mirror
MySQL Installation
Download - mysql-4.0.15-win.zip
http://www.mysql.com/....zip&pick=mirror
Unzip to a temp directory (anywhere is ok)
Run the setup and do a Typical install into H:/mysql directory
For re-install - Copy - my.ini to C:\WINDOWS directory
At the Command Prompt type
H: (you should see h:\>)
cd mysql\bin (you should see h:\mysql\bin>
mysqladmin -u root (you should see a long list of details)
net start mysql (you should get a message saying it was started successfully)

Installing DBI and DBD::MySQL-
http://perl.about.com/...weekly/aa032701b.htm



php-4.3.3-Win32.zip
http://www.php.net/...32.zip/from/a/mirror
PHP Installation
Download - php-4.3.3-Win32.zip
http://www.php.net/...32.zip/from/a/mirror
For new-install - Copy php.ini to C:\WINDOWS directory
For re-install - Copy your version of php.ini to C:\WINDOWS directory
For new-install - Copy - php.ini-recommend to C:\WINDOWS directory and re-name it php.ini
For new/re-install - Copy - php5ts.dll to C:\WINDOWS\system32 directory

After installing php, you should see the following in the Apache monitor -
Apache/2.0.47(Win32) PHP 4.3.3
Call up http://127.0.0.1/phpinfo.php or http://localhost/phpinfo.php
If you see the php info page then everything is ok.


DBManSQL Install
Copy install.cgi and install.dat to H:\httpdocs
Call up http://127.0.0.1/install.cgi
Follow the prompts/set paths (note Perl path was set to H:\usr\bin as it would recognize \usr\bin\perl) NOTE:
Wait till everything unpacks.
Click on the admin link - get server error
Change the shebang line to -
#!/usr/bin/perl
in every .cgi file in the admin folder.
Click on the admin link and follow prompts.
Got an error saying Perl DBI was not installed so typed -
ppm
at the command line (h:\>)
then typed -
install DBI
You should see -
PPM interactive shell (2.1.2) - type 'help' for available commands
PPM>


Next I installed the MySQL driver
At the PPM> prompt type -
search mysql
Doing so will return a list of available mysql-related modules. You should see something like
Packages available from http://[package repository url here]
ApacheMysql [0.3 ] Initiate a persistent database connection to Mysql
DBD-Mysql [1.2200] DBI driver for Mysql datasources
At the PPM> prompt type -
install DBD-Mysql

Reference: http://perl.about.com/...weekly/aa032701b.htm

Note: also installed the db_file perl module (needed for Ikonboard) using -
At the PPM> prompt type -
install db_file

Resubmit setup form.
Received error message to say the database didnft exist.
Created a database using database management software (Sqlyog).

Note: may need to change the path to perl in the Admin Setup to /usr/bin/perl.exe

cd mysql\bin
net start mysql
mysqladmin -u root
mysqladmin -u root -p status

Hope it works !!!!!!
Simon

Last edited by:

jai: Sep 1, 2005, 3:41 PM
Quote Reply
Re: [jai] DBManSQL on Localhost In reply to
Thanks - that worked!