Gossamer Forum
Home : Products : DBMan SQL : Discussion :

Back to Windoze

Quote Reply
Back to Windoze
I have just come back to windows after a long time away, (I tend to work with Macs nowadays) and I want to redevelop an old site of mine that used dbman in dbsql. However, I first need to get everything working and I cannot even run dbman or install dbsql at the moment. Here are the pertinent facts:

I am running windows XP under parallels on the mac.
I have installed the XAMPP (apache, perl, mysql, php) environment on my XP VM.
I have changed the path to perl properties accordingly.
I have tested a perltest.cgi in the localhost, it works fine.
I have extracted the dbsql package and copied install.cgi and install.dat to the cgi-bin.

Now the bits that dont work.

I try to run install.cgi under dos prompt, perl install.cgi, it doesn't work and I get the message:
Can't locate vars.pm in @INC (@INC contains: .) at install.cgi line 36.
BEGIN failed--compilation aborted at install.cgi line 36.

I tried to run perl install.cgi from telnet, it doesn't work at all:

Invalid Command. type ?/help for help

I tried to run it from the web, localhost/cgi-bin/install.cgi, and I get:

Server error!
The server encountered an internal error and was unable to complete your request.
Error message:
couldn't create child process: 720003: install.cgi
If you think this is a server error, please contact the webmaster.
Error 500
08/10/09 12:05:20
Apache/2.2.11 (Win32) DAV/2 mod_ssl/2.2.11 OpenSSL/0.9.8i PHP/5.2.9

If I try to use my old dbman scripts, set for localhost, I get the same error message as above.

These are the sort of reasons that I got away from windoze in the first place, but I do need this to work now. Does anyone have any ideas what is going on here. Perl is clearly working but why is dbman not and why does dbsql refuse to install?