Gossamer Forum
Home : Products : DBMan : Installation :

I'm getting this error message

Quote Reply
I'm getting this error message
I'm really stumped on this does any one have any ideas?

I am getting this error message:
All of the files are in the cgi-bin/dbman/
directory
<PRE>

CGI ERROR
==========================================
Error Message : Error loading required libraries.
Check that they exist, permissions are set correctly and that they compile.
Reason: Can't locate http://www.budgetlighting.com/cgi-bin/dbman/html.pl in @INC (@INC contains: http://www.budgetlighting.com/cgi-bin/dbman /usr/local/lib/perl5/alpha-dec_osf/5.00404 /usr/local/lib/perl5 /usr/local/lib/perl5/site_perl/alpha-dec_osf /usr/local/lib/perl5/site_perl .) at default.cfg line 57.

Script Location : db.cgi
Perl Version : 5.00404
Setup File : default.cfg

Form Variables
-------------------------------------------

Environment Variables
-------------------------------------------
DOCUMENT_ROOT : /a1/www/www.budgetlighting.com/docs
GATEWAY_INTERFACE : CGI/1.1
HTTP_ACCEPT : */*
HTTP_ACCEPT_ENCODING: gzip, deflate
HTTP_ACCEPT_LANGUAGE: en-us
HTTP_HOST : www.budgetlighting.com
HTTP_IF_MODIFIED_SINCE: Mon, 11 Jan 1999 03:58:28 GMT; length=1343
HTTP_REFERER : http://www.budgetlighting.com/cgi-bin/dbman/
HTTP_USER_AGENT : Mozilla/4.0 (compatible; MSIE 4.01; Windows 98)
PATH : /usr/local/bin:/usr/bin:/bin
QUERY_STRING :
REMOTE_ADDR : 167.142.10.110
REMOTE_HOST : desm-01-45.dialup.netins.net
REMOTE_PORT : 1538
REQUEST_METHOD : GET
SCRIPT_FILENAME : /a1/www/www.budgetlighting.com/docs/cgi-bin/dbman/db.cgi
SCRIPT_NAME : /cgi-bin/dbman/db.cgi
SERVER_ADMIN : webmaster@www.budgetlighting.com
SERVER_NAME : www.budgetlighting.com
SERVER_PORT : 80
SERVER_PROTOCOL : HTTP/1.0
SERVER_SOFTWARE : Apache/1.3b3

</PRE>
How do I fix this?

Also I noticed that I can't set the file permissions on some of the files, I try but they go back to where they were.

I am feeling out of my element right now.
Thanks
Steve


[This message has been edited by Steve Border (edited January 10, 1999).]

[This message has been edited by Steve Border (edited January 13, 1999).]
Subject Author Views Date
Thread I'm getting this error message Steve Border 1356 Jan 10, 1999, 7:03 PM
Post Re: I'm getting this error message
ZigZag 1279 Jan 11, 1999, 2:53 AM