Gossamer Forum
Home : Products : DBMan : Installation :

Can't Log In

Quote Reply
Can't Log In

I am running DBMan on a Cobalt RAQ server (if that makes a difference). I have set up the script; it seems to be working fine, but there's one problem: When I log in, I am returned to the login screen. When I first installed the script I used "admin" as the username and "admin" as the password, but I was just retuned to the login screen...no error messages or anything.

So I erased all the passwords and usernames, changed the permissions so that I could log in as "default" and went to the admin screen. I tried creating a new user, but was bounced back to the login screen. Again, no error message or anything.

The script is located at http://www.simplitech.com/~dev/db.cgi. I have it set up with username "david" and password "david".

Could it have something to do with CGIWrap? I heard that mentioned in some earlier posts. Unfortunately, I have no idea what CGIWrap is and how to (if i can) disable it or work around it.

Any help would be greatly appreciated.

Dave Schuster

Quote Reply
Re: Can't Log In In reply to
I would recommend using the DEFAULT out-of-the-box default.pass file...at least the admin entry...put it in your current .pass file.

Then login as admin.

Also double check your AUTHENTICATION PERMISSIONS in the default.cfg file. Check them against the tutorial pages at:



Eliot Lee
Quote Reply
Re: Can't Log In In reply to
Anthro- I tried what you suggested below:

\Log in with username: admin and password: admin
If the username and password don't work, go through the following steps:

1. Erase all entries in the password file (default.pass).
2. Save default.pass.
3. Set $auth_allow_default = 1; (in the default.cfg file)
4. Set @auth_default_permissions = (1,1,1,1,1); (in the default.cfg file)
5. Save default.cfg.
6. Upload default.pass and default.cfg -- in ASCII mode! -- You shouldn't have to set the permissions again.
7. Go to http://server/cgi-bin/dbman/db.cgi?db=default&uid=default
8. Go to Admin and add your own username and password. Be sure to check all the checkboxes at the bottom of the screen when you add your username.

That should be it! Reset the authentication back to what you want when you are done.

It still doesn't work I even tried turning the flock off but that didn't work either.

I have the same problem as the original poster

Raymond Mills

Tradeshows Online
Quote Reply
Re: Can't Log In In reply to
O.K. I restored the password file from the original zip file. I also restored the authentication settings. A copy of my password file is located at:


and my config file is located at:


When I try using "admin" and "admin" I'm just returned back to the login screen. Any suggestions?

Quote Reply
Re: Can't Log In In reply to
I've run into a very similiar situation...did you ever find a resolution? I'm getting:

"DBMan encountered an internal error. Please enable debugging to view."


DBMan encountered an internal error.

Error Message : Debug Information
Script Location : c:\inetpub\wwwroot\survey\cgi-bin\dbman\db.pl
Perl Version : 5.006
Setup File : default.cfg

Form Variables

Pete Coleman

Quote Reply
Re: Can't Log In In reply to
I actually switched servers and disabled FrontPage extensions (not sure which change did the trick). After that the script has been working fine.

-Dave Schuster