Gossamer Forum
Home : Products : DBMan : Installation :

Authority Settings on a Unix Server

Quote Reply
Authority Settings on a Unix Server
When I allow a default user on the authorization settings I can then no longer get to a logon screen. I am on a unix server which I think is the problem. I have tried to modify the auth.cgi with advice from someone else but this still doesn't work.
Is there any know cure for this?

$auth_no_authentication = 0;
$auth_allow_default = 1;
@auth_default_permissions = (1,0,0,0,0);
$auth_signup = 1;
@auth_signup_permissions = (1,1,1,1,0);
$auth_modify_own = 1;
$auth_view_own = 0;

Basically I want to anyone to see the database but people who are registered can update their own files.

Admin can do anything.


Quote Reply
Re: Authority Settings on a Unix Server In reply to
The default user does'nt log in. To enter the database as a default user, link to the database like so:

- Mark

Quote Reply
Re: Authority Settings on a Unix Server In reply to
I wish the problem was that simple, but thanks for taking the time to reply.

I can set up a default user and the seach works well. The problem is that if I do set up the default then I can't get to any logon screens. Once I turn the default user off I can logon but I can't search using a default user (obviously!).

Tried everything.

Quote Reply
Re: Authority Settings on a Unix Server In reply to
You'll need to post your default.cfg as a text file in order to have someone review the file to look for possible conflicts. Noticed in another thread you mentioned having changed the file names, because you are on a "unix" server. Most unix servers will run .cgi and .pl files, don't understand why the change was needed.

Essentially, with a "default" user - you establish links for the default users to access your db - you provide the &uid=default portion (authentication) within the link. Registered users should still be using http://yourdomain.com/path/to/db.cgi to login to the database. Having a default user option does not change the login process.