Gossamer Forum
Home : Gossamer Threads Inc. : Discussion :

Problems with %

Quote Reply
Problems with %
In the old forum, we had problems posting code because of two things:

;) would be turned into a "winky" face
|| would be displayed with a space between the pipes

I'm so pleased that the current forum doesn't do that.

But there's now a problem with the % sign. If I refer to a hash by its appropriate name -- _def -- well, you can see what happens. The only way to get it to print a % is to put a space in like -- % db_def. Sometimes it works okay. Seems that I can use %rec as a hash name.

It's really hard to remember to tell people to take out the space and I can envision multitudes of problems with people coming back and saying "the code you gave me doesn't work."

Is there any way to fix this? Or at least be able to predict when it's going to be a problem?

JPD
http://www.jpdeni.com/dbman/
Quote Reply
Re: Problems with % In reply to
Yes, Carol...very annoying problem...I posted this bug in the following Thread:

http://www.gossamer-threads.com/...w=collapsed&sb=5

and I received no response from Gossamer Threads staff members.

Wink

Regards,

Eliot Lee
Quote Reply
Re: Problems with % In reply to
I read that thread again, but I must have missed where you talked about the problem with the %.

But it's not so bad to repeat it, since it's a real problem.

JPD
http://www.jpdeni.com/dbman/
Quote Reply
Re: Problems with % In reply to
I agree...

I posted the problem in the VERY LAST Post in the Thread I linked.

Wink

Regards,

Eliot Lee
Quote Reply
Re: Problems with % In reply to
Thanks JPDeni and Eliot, I've fixed this up. (I was away until today so sorry about the late reply!).

Cheers,

Alex

--
Gossamer Threads Inc.
Quote Reply
Re: Problems with % In reply to
Thank you, Alex!! (How was the cruise? Smile)

I just realized that I used a % in a post just a few minutes ago and didn't check it. I'll go back and look at it and marvel at your expertise!! Smile

JPD
http://www.jpdeni.com/dbman/
Quote Reply
Re: Problems with % In reply to
Yep...it works. Smile

Thanks, Alex.

Regards,