Gossamer Forum
Quote Reply
POP3
I've written a script to parse emails because AFAIK there are no cpan modules to actually just grab the body of an email...you get all the headers and html too.

Anyway as part of the script I need to grab the subject...thats pretty easy however I got Carsten to send me one in Japanese and the email subject turns into something like:

=?ISO-2022-JP?B?GyRCJEYkOSRIGyhCLXRlc3Q=?=

...however the body shows pretty much correctly. I thought this was a bug in my code but I opened the email in Outlook and "Properties" > "Details" shows exactly the same code for the subject line yet it displays properly as Japanese text in my inbox.

Does anyone know what is causing this and can it be fixed?

I'm assuming that if Outlook has the same issue then it is either a bug or unfixable?
Subject Author Views Date
Thread POP3 Paul 7917 May 30, 2002, 2:25 AM
Thread Re: [Paul] POP3
Wil 7715 May 30, 2002, 2:57 AM
Post Re: [Wil] POP3
Paul 7718 May 30, 2002, 3:20 AM
Thread Re: [Paul] POP3
Alex 7703 May 30, 2002, 8:15 AM
Thread Re: [Alex] POP3
Paul 7669 May 30, 2002, 8:18 AM
Thread Re: [Paul] POP3
Alex 7645 May 30, 2002, 8:23 AM
Thread Re: [Alex] POP3
Paul 7657 May 30, 2002, 8:49 AM
Thread Re: [Paul] POP3
Alex 7596 May 30, 2002, 5:12 PM
Thread Re: [Alex] POP3
Paul 7581 May 31, 2002, 12:37 AM
Thread Re: [Paul] POP3
QooQ 7585 May 31, 2002, 3:03 AM
Thread Re: [QooQ] POP3
Paul 7607 May 31, 2002, 3:25 AM
Post Re: [Paul] POP3
dixi 6934 Mar 19, 2004, 4:14 AM
Post Re: [Alex] POP3
Paul 7621 May 30, 2002, 9:52 AM
Post Re: [Alex] POP3
Paul 7632 May 30, 2002, 10:28 AM
Post Re: [Paul] POP3
Paul 7609 May 30, 2002, 10:54 AM