Gossamer Forum
Home : Products : Gossamer Links : Development, Plugins and Globals :

Error after Upgrade to Centos 7

Quote Reply
Error after Upgrade to Centos 7
Dear All,

I have problem after my server crash few years ago and starting yesterday i try to make my site up back with Centos 7 and Perl 5.16.3, The error when try to access admin.cgi and on apache error log shown as:

Wed Sep 05 05:59:57.764678 2018] [cgid:error] [pid 18707:tid 140659826579200] [client xxx.xxx.xxx.xxx:49391] End of script output before headers: admin.cgi
suexec policy violation: see suexec log for more details

And when i try to execute:

perl /home/xxxxxx/public_html/xxxxx/cgi-bin/admin/admin.cgi

Its shown:

defined(@array) is deprecated at /home/xxxxxx/public_html/xxxxxx/cgi-bin/admin/GT/Base.pm line 235.
(Maybe you should just omit the defined()?)
Content-type: text/html

defined(%hash) is deprecated at (eval 3) line 31.
(Maybe you should just omit the defined()?)

<html>
<head>
<title>Links SQL 2.1.1 Administration</title>
</head>

<frameset rows="70,*">
<frame name="nav" src="admin.cgi?page=home_nav.html" scrolling="no" noresize frameborder="0" target="main">
<frame name="body" src="admin.cgi?page=home_body.html" frameborder="0">
<noframes>
<body bgcolor="#FFFFFF">

<p>Links SQL requires you to use a frames enabled browser..</p>

</body>
</noframes>
</frameset>

The error refered to Base.pm line 235 is:

my @pkg_isa = defined @{"$class\:\:ISA"} ? @{"$class\:\:ISA"} : ();



How can i fix that? Please help. TQ
Subject Author Views Date
Thread Error after Upgrade to Centos 7 reenee 1742 Sep 4, 2018, 3:22 AM
Thread Re: [reenee] Error after Upgrade to Centos 7
Andy 1727 Sep 4, 2018, 5:52 AM
Thread Re: [Andy] Error after Upgrade to Centos 7
reenee 1724 Sep 4, 2018, 6:04 AM
Thread Re: [reenee] Error after Upgrade to Centos 7
Andy 1717 Sep 4, 2018, 6:16 AM
Thread Re: [Andy] Error after Upgrade to Centos 7
reenee 1714 Sep 4, 2018, 7:05 AM
Thread Re: [reenee] Error after Upgrade to Centos 7
Andy 1710 Sep 4, 2018, 7:07 AM
Thread Re: [Andy] Error after Upgrade to Centos 7
reenee 1700 Sep 4, 2018, 12:33 PM
Post Re: [reenee] Error after Upgrade to Centos 7
Andy 1688 Sep 4, 2018, 11:35 PM