Gossamer Forum
Home : Products : Gossamer Links : Discussions :

File Attachments

Quote Reply
File Attachments

I've been experiencing a problem - since changing server for some reason.

I have a number of FILE Columns in my table. An example is here:-

Column Name : Abc_Attachment
Column Type : CHAR
Column Index : None
Column Size : 255
Not Null : No
Form Type : FILE
File Save Location : /path/one/directory/up/from/html/directory
(directories were 755 then tried chmod 777)

I can add a file okay from Admin - uploads into the File Save Location (verified)

To call the File which is to download it I have the following in my template:-

<%if Abc_Attachment~%>
<a href="<%config.db_cgi_url%>/jump.cgi?ID=<%ID%>;download=Abc_Attachment">Download the Attachment</a>
When I initially upload the file ie. press Modify from Admin the file shows up (download _ view).

When I do a search for the same link the attachment is not shown.

When I try a modify again the attachment is not shown.

In my template (above) it displays the attachment.

When I try and download it from the detailed page - I get an error page - unable to find file (also get the same error from Admin).

The Attachment File Name does exist in the Table (checked mysqlman).

Does anyone have any ideas on what could possibly be wrong here?


The Affiliate Programs Directory
Subject Author Views Date
Thread File Attachments Clint 2388 May 23, 2011, 3:05 AM
Post Re: [Clint] File Attachments
Andy 2309 May 23, 2011, 5:46 AM
Post Re: [Clint] File Attachments
Andy 2203 May 29, 2011, 6:44 AM